# CVE-2021-2007: Information disclosure in MySQL Server

> An unauthenticated attacker can exploit a difficult-to-exploit vulnerability in the MySQL Client C API to gain unauthorized read access to a subset of accessible data.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jan 2021
- **Updated:** 26 Sep 2024
- **Also known as:** BIT-mariadb-2021-2007, BIT-mariadb-min-2021-2007, BIT-mysql-client-2021-2007, GHSA-62m3-j4w3-p5mw, UBUNTU-CVE-2021-2007

## What is CVE-2021-2007?

CVE-2021-2007 is a low-severity vulnerability in Fedoraproject Fedora, published on 20 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in the MySQL Client product of Oracle MySQL (component: C API). Supported versions that are affected are 5.6.47 and prior, 5.7.29 and prior and 8.0.19 and prior. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise MySQL Client. Successful attacks of this vulnerability can result in unauthorized read access to a subset of MySQL Client accessible data. CVSS 3.1 Base Score 3.7 (Confidentiality impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N).

## Which versions are affected by CVE-2021-2007?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | From 5.5.0 | 5.5.65, 10.1.41, 10.2.26, 10.3.17, 10.4.7 |
| `mariadb-min` | Bitnami | From 5.5.0 | 5.5.65, 10.1.41, 10.2.26, 10.3.17, 10.4.7 |
| `mysql-client` | Bitnami | From 5.5.0 | 5.5.65, 10.1.41, 10.2.26, 10.3.17, 10.4.7 |

Products: Fedoraproject Fedora, Mariadb Mariadb, Netapp Active Iq Unified Manager, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Oracle Mysql.

## How do I fix CVE-2021-2007?

Upgrade mariadb to a fixed version for your release line: 5.5.65, 10.1.41, 10.2.26 or 10.3.17.

## Is CVE-2021-2007 being exploited?

There is no known exploitation of CVE-2021-2007 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-2007 and fix it if it is affected.

What it is: CVE-2021-2007 is a low-severity vulnerability in Fedoraproject Fedora, published on 20 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-2007 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected from 5.5.0; fixed in 5.5.65, 10.1.41, 10.2.26, 10.3.17, 10.4.7
- mariadb-min (Bitnami): affected from 5.5.0; fixed in 5.5.65, 10.1.41, 10.2.26, 10.3.17, 10.4.7
- mysql-client (Bitnami): affected from 5.5.0; fixed in 5.5.65, 10.1.41, 10.2.26, 10.3.17, 10.4.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-2007/ (Markdown: https://insights.sbomify.com/CVE-2021-2007/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-2007
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-2007
- OSV: https://osv.dev/vulnerability/CVE-2021-2007

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-2007/
Summaries are generated and may contain mistakes; the official description above is the record.
