{"answers":{"affected":"3 open source packages ship an affected version, including ansible. It affects 3 products.","exploited":"There is no known exploitation of CVE-2021-20178 in the wild and no public exploit code.","fix":"Upgrade ansible to 2.9.18 or later.","what":"CVE-2021-20178 is a medium-severity vulnerability in Fedoraproject Fedora, published on 26 May 2021. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-20178 and fix it if it is affected.\n\nWhat it is: CVE-2021-20178 is a medium-severity vulnerability in Fedoraproject Fedora, published on 26 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-20178 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected all versions; fixed in 2.9.18\n- ansible (PyPI): affected all versions; fixed in 2.9.18\n- ansible (PyPI): affected all versions; fixed in 2.9.18\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-20178/ (Markdown: https://insights.sbomify.com/CVE-2021-20178/index.md)","id":"CVE-2021-20178","markdown":"https://insights.sbomify.com/CVE-2021-20178/index.md","name":"CVE-2021-20178","record":{"aliases":["DEBIAN-CVE-2021-20178","GHSA-wv5p-gmmv-wh9v","PYSEC-2021-106","UBUNTU-CVE-2021-20178"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ansible module","requires_auth":"low_privilege","summary":"An attacker can steal Bitbucket pipeline credentials from console logs due to lack of protection in the Ansible module.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"ansible","vendor":"redhat"},{"product":"ansible_tower","vendor":"redhat"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-532","name":"Insertion of Sensitive Information into Log File"}],"description":"A flaw was found in ansible module where credentials are disclosed in the console log by default and not protected by the security feature when using the bitbucket_pipeline_variable module. This flaw allows an attacker to steal bitbucket_pipeline credentials. The highest threat from this vulnerability is to confidentiality.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Insertion of Sensitive Information into Log File in ansible","id":"CVE-2021-20178","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora","redhat:ansible_tower"],"type":"information_disclosure","year":"2021"},"n_packages":3,"n_references":6,"next":{"headline":"Business logic in pki-core","id":"CVE-2021-20179"},"packages":[{"ecosystem":"PyPI","fixed":["2.9.18"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-wv5p-gmmv-wh9v"},{"ecosystem":"PyPI","fixed":["2.9.18"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-wv5p-gmmv-wh9v"},{"ecosystem":"PyPI","fixed":["2.9.18"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2021-106"}],"prev":{"headline":"Denial of service in kernel","id":"CVE-2021-20177"},"products":["Ansible"],"published":"2021-05-26","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"An attacker can steal Bitbucket pipeline credentials from console logs due to lack of protection in the Ansible module.","url":"https://insights.sbomify.com/CVE-2021-20178/"}