# CVE-2021-20178: Insertion of Sensitive Information into Log File in ansible

> An attacker can steal Bitbucket pipeline credentials from console logs due to lack of protection in the Ansible module.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-20178, GHSA-wv5p-gmmv-wh9v, PYSEC-2021-106, UBUNTU-CVE-2021-20178

## What is CVE-2021-20178?

CVE-2021-20178 is a medium-severity vulnerability in Fedoraproject Fedora, published on 26 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A flaw was found in ansible module where credentials are disclosed in the console log by default and not protected by the security feature when using the bitbucket_pipeline_variable module. This flaw allows an attacker to steal bitbucket_pipeline credentials. The highest threat from this vulnerability is to confidentiality.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2021-20178?

3 open source packages ship an affected version, including ansible. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 2.9.18 |
| `ansible` | PyPI | All versions | 2.9.18 |
| `ansible` | PyPI | All versions | 2.9.18 |

Products: Fedoraproject Fedora, Redhat Ansible, Redhat Ansible Tower.

## How do I fix CVE-2021-20178?

Upgrade ansible to 2.9.18 or later.

## Is CVE-2021-20178 being exploited?

There is no known exploitation of CVE-2021-20178 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-20178 and fix it if it is affected.

What it is: CVE-2021-20178 is a medium-severity vulnerability in Fedoraproject Fedora, published on 26 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-20178 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 2.9.18
- ansible (PyPI): affected all versions; fixed in 2.9.18
- ansible (PyPI): affected all versions; fixed in 2.9.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-20178/ (Markdown: https://insights.sbomify.com/CVE-2021-20178/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-20178
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-20178
- OSV: https://osv.dev/vulnerability/CVE-2021-20178

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-20178/
Summaries are generated and may contain mistakes; the official description above is the record.
