CVE-2021-20183 Moodle Vulnerable to Reflected Cross-site Scripting
Attackers can execute arbitrary scripts in victim browsers via reflected XSS in Moodle search inputs, potentially leading to session hijacking.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-20183?
CVE-2021-20183 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 28 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
It was found in Moodle before version 3.10.1 that some search inputs were vulnerable to reflected XSS due to insufficient escaping of search queries.
Weakness: CWE-79
Which versions are affected by CVE-2021-20183?
3 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10 | 4.0.0-beta |
moodle/moodle Packagist | From 3.10 | 4.0.0-beta |
moodle Bitnami | All versions | 3.10.1 |
Products include Moodle Moodle.
How do I fix CVE-2021-20183?
Upgrade moodle/moodle to 4.0.0-beta or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-20183 being exploited?
There is no known exploitation of CVE-2021-20183 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2021-20183, GHSA-xhfx-rm8q-c3xv, UBUNTU-CVE-2021-20183.