CVE-2021-20184 Moodle Grade information disclosure in grade's external fetch functions
Students can view other students' grades due to insufficient capability checks in Moodle grade-related web services.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-20184?
CVE-2021-20184 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 28 Jan 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
It was found in Moodle before version 3.10.1, 3.9.4 and 3.8.7 that a insufficient capability checks in some grade related web services meant students were able to view other students grades.
Weakness: CWE-354
Which versions are affected by CVE-2021-20184?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10 | 3.10.1 |
moodle/moodle Packagist | From 3.10 | 3.10.1 |
moodle/moodle Packagist | From 3.8 | 3.8.7 |
moodle/moodle Packagist | From 3.8 | 3.8.7 |
moodle/moodle Packagist | From 3.9 | 3.9.4 |
moodle/moodle Packagist | From 3.9 | 3.9.4 |
1 more packages
moodle Bitnami | All versions | 3.8.7, 3.9.4, 3.10.1 |
Products include Moodle Moodle.
How do I fix CVE-2021-20184?
Upgrade moodle/moodle to a fixed version for your release line: 3.10.1, 3.8.7 or 3.9.4.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-20184 being exploited?
There is no known exploitation of CVE-2021-20184 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2021-20184, GHSA-mm73-86f9-5x5c, UBUNTU-CVE-2021-20184.