CVE-2021-20185 Moodle Client side denial of service via personal message
Attackers can cause browser denial of service for Moodle users by sending messages without character limits, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-20185?
CVE-2021-20185 is a medium-severity denial of service vulnerability in Moodle Moodle, published on 28 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that messaging did not impose a character limit when sending messages, which could result in client-side (browser) denial of service for users receiving very large messages.
Which versions are affected by CVE-2021-20185?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10 | 3.10.1 |
moodle/moodle Packagist | From 3.10 | 3.10.1 |
moodle/moodle Packagist | From 3.5 | 3.5.16 |
moodle/moodle Packagist | From 3.5 | 3.5.16 |
moodle/moodle Packagist | From 3.8 | 3.8.7 |
moodle/moodle Packagist | From 3.8 | 3.8.7 |
3 more packages
moodle/moodle Packagist | From 3.9 | 3.9.4 |
moodle/moodle Packagist | From 3.9 | 3.9.4 |
moodle Bitnami | From 3.5.0 | 3.5.16, 3.8.7, 3.9.4, 3.10.1 |
Products include Moodle Moodle.
How do I fix CVE-2021-20185?
Upgrade moodle/moodle to a fixed version for your release line: 3.10.1, 3.5.16, 3.8.7 or 3.9.4.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-20185 being exploited?
There is no known exploitation of CVE-2021-20185 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2021-20185, GHSA-c3j6-33r4-89q3, UBUNTU-CVE-2021-20185.