CVE-2021-20186 Moodle Cross-site Scripting
Stored XSS in Moodle's TeX notation filter allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-20186?
CVE-2021-20186 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 28 Jan 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that if the TeX notation filter was enabled, additional sanitizing of TeX content was required to prevent the risk of stored XSS.
Weakness: CWE-79
Which versions are affected by CVE-2021-20186?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10 | 3.10.1 |
moodle/moodle Packagist | From 3.10 | 3.10.1 |
moodle/moodle Packagist | From 3.5 | 3.5.16 |
moodle/moodle Packagist | From 3.5 | 3.5.16 |
moodle/moodle Packagist | From 3.8 | 3.8.7 |
moodle/moodle Packagist | From 3.8 | 3.8.7 |
3 more packages
moodle/moodle Packagist | From 3.9 | 3.9.4 |
moodle/moodle Packagist | From 3.9 | 3.9.4 |
moodle Bitnami | All versions | 3.5.16, 3.8.7, 3.9.4, 3.10.1 |
Products include Moodle Moodle.
How do I fix CVE-2021-20186?
Upgrade moodle/moodle to a fixed version for your release line: 3.10.1, 3.5.16, 3.8.7 or 3.9.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-20186 being exploited?
There is no known exploitation of CVE-2021-20186 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2021-20186, GHSA-h8m4-h385-qhqv, UBUNTU-CVE-2021-20186.