CVE-2021-20187 Moodle Arbitrary PHP code execution by site admins via Shibboleth configuration
Site administrators can execute arbitrary PHP scripts via a vulnerable include in Shibboleth authentication, requiring this feature to be enabled.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-20187?
CVE-2021-20187 is a high-severity code injection vulnerability in Moodle Moodle, published on 28 Jan 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that it was possible for site administrators to execute arbitrary PHP scripts via a PHP include used during Shibboleth authentication.
Which versions are affected by CVE-2021-20187?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10 | 3.10.1 |
moodle/moodle Packagist | From 3.10 | 3.10.1 |
moodle/moodle Packagist | From 3.5 | 3.5.16 |
moodle/moodle Packagist | From 3.5 | 3.5.16 |
moodle/moodle Packagist | From 3.8 | 3.8.7 |
moodle/moodle Packagist | From 3.8 | 3.8.7 |
3 more packages
moodle/moodle Packagist | From 3.9 | 3.9.4 |
moodle/moodle Packagist | From 3.9 | 3.9.4 |
moodle Bitnami | All versions | 3.5.16, 3.8.7, 3.9.4, 3.10.1 |
Products include Moodle Moodle.
How do I fix CVE-2021-20187?
Upgrade moodle/moodle to a fixed version for your release line: 3.10.1, 3.5.16, 3.8.7 or 3.9.4.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2021-20187 being exploited?
There is no known exploitation of CVE-2021-20187 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2021-20187, GHSA-2jrm-gww7-wch2, UBUNTU-CVE-2021-20187.