{"answers":{"affected":"9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-20187 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 3.10.1, 3.5.16, 3.8.7 or 3.9.4.","what":"CVE-2021-20187 is a high-severity code injection vulnerability in Moodle Moodle, published on 28 Jan 2021. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-20187 and fix it if it is affected.\n\nWhat it is: CVE-2021-20187 is a high-severity code injection vulnerability in Moodle Moodle, published on 28 Jan 2021. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-20187 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 3.10; fixed in 3.10.1\n- moodle/moodle (Packagist): affected from 3.10; fixed in 3.10.1\n- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.16\n- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.16\n- moodle/moodle (Packagist): affected from 3.8; fixed in 3.8.7\n- moodle/moodle (Packagist): affected from 3.8; fixed in 3.8.7\n- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.4\n- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.4\n- moodle (Bitnami): affected all versions; fixed in 3.5.16, 3.8.7, 3.9.4, 3.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-20187/ (Markdown: https://insights.sbomify.com/CVE-2021-20187/index.md)","id":"CVE-2021-20187","markdown":"https://insights.sbomify.com/CVE-2021-20187/index.md","name":"CVE-2021-20187","record":{"aliases":["BIT-moodle-2021-20187","GHSA-2jrm-gww7-wch2","UBUNTU-CVE-2021-20187"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Moodle LMS","requires_auth":"high_privilege","summary":"Site administrators can execute arbitrary PHP scripts via a vulnerable include in Shibboleth authentication, requiring this feature to be enabled.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":7.2,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"},{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that it was possible for site administrators to execute arbitrary PHP scripts via a PHP include used during Shibboleth authentication.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle Arbitrary PHP code execution by site admins via Shibboleth configuration","id":"CVE-2021-20187","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"code_injection","year":"2021"},"n_packages":9,"n_references":1,"next":{"headline":"Improper Authorization in github.com/containers/libpod","id":"CVE-2021-20188"},"packages":[{"ecosystem":"Bitnami","fixed":["3.5.16","3.8.7","3.9.4","3.10.1"],"introduced":["0","3.8.0","3.9.0","3.10.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2021-20187"},{"ecosystem":"Packagist","fixed":["3.10.1"],"introduced":["3.10"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-2jrm-gww7-wch2"},{"ecosystem":"Packagist","fixed":["3.10.1"],"introduced":["3.10"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-2jrm-gww7-wch2"},{"ecosystem":"Packagist","fixed":["3.5.16"],"introduced":["3.5"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-2jrm-gww7-wch2"},{"ecosystem":"Packagist","fixed":["3.5.16"],"introduced":["3.5"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-2jrm-gww7-wch2"},{"ecosystem":"Packagist","fixed":["3.8.7"],"introduced":["3.8"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-2jrm-gww7-wch2"},{"ecosystem":"Packagist","fixed":["3.8.7"],"introduced":["3.8"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-2jrm-gww7-wch2"},{"ecosystem":"Packagist","fixed":["3.9.4"],"introduced":["3.9"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-2jrm-gww7-wch2"},{"ecosystem":"Packagist","fixed":["3.9.4"],"introduced":["3.9"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-2jrm-gww7-wch2"}],"prev":{"headline":"Moodle Cross-site Scripting","id":"CVE-2021-20186"},"products":["moodle"],"published":"2021-01-28","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Site administrators can execute arbitrary PHP scripts via a vulnerable include in Shibboleth authentication, requiring this feature to be enabled.","url":"https://insights.sbomify.com/CVE-2021-20187/"}