# CVE-2021-20190: Deserialization of untrusted data in jackson-databind

> Attackers can exploit unsafe deserialization in jackson-databind to execute arbitrary code or cause denial of service.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2021
- **Updated:** 27 Aug 2025
- **Also known as:** BIT-nifi-2021-20190, CLEANSTART-2026-RI88730, DEBIAN-CVE-2021-20190, GHSA-5949-rw7g-wx7w, ROOT-APP-MAVEN-CVE-2021-20190, UBUNTU-CVE-2021-20190

## What is CVE-2021-20190?

CVE-2021-20190 is a high-severity unsafe deserialization vulnerability in Apache Nifi, published on 19 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in jackson-databind before 2.9.10.7. FasterXML mishandles the interaction between serialization gadgets and typing. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2021-20190?

5 open source packages ship an affected version, including nifi and com.fasterxml.jackson.core:jackson-databind. It affects 9 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nifi` | Bitnami | From 1.7.0 to 1.12.1 | None |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | All versions | 2.6.7.5 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | All versions | 2.6.7.5 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.7.0 | 2.9.10.7 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.7.0 | 2.9.10.7 |

Products: Apache Nifi, Debian Debian Linux, Fasterxml Jackson-Databind, Netapp Active Iq Unified Manager, Netapp Oncommand Api Services, Netapp Oncommand Insight, Netapp Service Level Manager, Oracle Commerce Experience Manager, Oracle Commerce Guided Search.

## How do I fix CVE-2021-20190?

Upgrade to a fixed version.

## Is CVE-2021-20190 being exploited?

There is no known exploitation of CVE-2021-20190 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-20190 and fix it if it is affected.

What it is: CVE-2021-20190 is a high-severity unsafe deserialization vulnerability in Apache Nifi, published on 19 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-20190 in the wild and no public exploit code.

Affected packages and fixed versions:
- nifi (Bitnami): affected from 1.7.0 up to 1.12.1; no fix listed
- com.fasterxml.jackson.core:jackson-databind (Maven): affected all versions; fixed in 2.6.7.5
- com.fasterxml.jackson.core:jackson-databind (Maven): affected all versions; fixed in 2.6.7.5
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.7.0; fixed in 2.9.10.7
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.7.0; fixed in 2.9.10.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-20190/ (Markdown: https://insights.sbomify.com/CVE-2021-20190/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-20190
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-20190
- OSV: https://osv.dev/vulnerability/CVE-2021-20190

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-20190/
Summaries are generated and may contain mistakes; the official description above is the record.
