# CVE-2021-20195: keycloak Self Stored Cross-site Scripting vulnerability

> Attackers can execute arbitrary JavaScript via stored XSS in Keycloak, leading to complete account takeover and system compromise.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-q6w2-89hq-hq27

## What is CVE-2021-20195?

CVE-2021-20195 is a critical cross-site scripting vulnerability in Redhat Keycloak, published on 28 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A flaw was found in keycloak in versions before 13.0.0. A Self Stored XSS attack vector escalating to a complete account takeover is possible due to user-supplied data fields not being properly encoded and Javascript code being used to process the data. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Weakness: CWE-116 (Improper Encoding or Escaping of Output), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-20195?

2 open source packages ship an affected version, including org.keycloak:keycloak-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-core` | Maven | All versions | 13.0.0 |
| `org.keycloak:keycloak-core` | Maven | All versions | 13.0.0 |

Products: Redhat Keycloak.

## How do I fix CVE-2021-20195?

Upgrade org.keycloak:keycloak-core to 13.0.0 or later.

## Is CVE-2021-20195 being exploited?

There is no known exploitation of CVE-2021-20195 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Keycloak

- [CVE-2022-4361](https://insights.sbomify.com/CVE-2022-4361/): Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC (critical 10.0)
- [CVE-2022-1245](https://insights.sbomify.com/CVE-2022-1245/): Keycloak vulnerable to privilege escalation on Token Exchange feature (critical 9.8)
- [CVE-2019-14910](https://insights.sbomify.com/CVE-2019-14910/): Keycloak Authentication Error (critical 9.3)
- [CVE-2019-14909](https://insights.sbomify.com/CVE-2019-14909/): Keycloak Authentication Error (critical 9.3)
- [CVE-2022-3782](https://insights.sbomify.com/CVE-2022-3782/): Keycloak vulnerable to path traversal via double URL encoding (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-20195 and fix it if it is affected.

What it is: CVE-2021-20195 is a critical cross-site scripting vulnerability in Redhat Keycloak, published on 28 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-20195 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 13.0.0
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 13.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-20195/ (Markdown: https://insights.sbomify.com/CVE-2021-20195/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-20195
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-20195
- OSV: https://osv.dev/vulnerability/CVE-2021-20195

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-20195/
Summaries are generated and may contain mistakes; the official description above is the record.
