# CVE-2021-20201: Denial of service in spice

> Remote attackers can cause denial of service via CPU consumption by performing many renegotiations in a single connection.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2021-20201, ALSA-2021:1924, CLSA-2026-1778489013, DEBIAN-CVE-2021-20201, GHSA-f3pm-m5m9-45gw, MGASA-2021-0405, OESA-2021-1233, RHSA-2021:1924, RLSA-2021:1924, SUSE-SU-2021:1906-1, SUSE-SU-2021:1927-1, SUSE-SU-2022:2881-1, SUSE-SU-2022:2881-2, UBUNTU-CVE-2021-20201, openSUSE-SU-2021:0874-1, openSUSE-SU-2024:12406-1, openSUSE-SU-2024:13045-1

## What is CVE-2021-20201?

CVE-2021-20201 is a medium-severity denial of service vulnerability in Redhat Enterprise Linux, published on 28 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in spice in versions before 0.14.92. A DoS tool might make it easier for remote attackers to cause a denial of service (CPU consumption) by performing many renegotiations within a single connection.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-20201?

It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `spice-server` | AlmaLinux:8 | All versions | 0.14.3-4.el8 |
| `spice-server-devel` | AlmaLinux:8 | All versions | 0.14.3-4.el8 |
| `spice` | Red Hat:enterprise_linux:8::appstream | All versions | 0:0.14.3-4.el8 |
| `spice-debugsource` | Red Hat:enterprise_linux:8::appstream | All versions | 0:0.14.3-4.el8 |
| `spice-server` | Red Hat:enterprise_linux:8::appstream | All versions | 0:0.14.3-4.el8 |
| `spice-server-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:0.14.3-4.el8 |
| `spice-debugsource` | Red Hat:enterprise_linux:8::crb | All versions | 0:0.14.3-4.el8 |
| `spice-server-debuginfo` | Red Hat:enterprise_linux:8::crb | All versions | 0:0.14.3-4.el8 |
| `spice-server-devel` | Red Hat:enterprise_linux:8::crb | All versions | 0:0.14.3-4.el8 |
| `spice` | Rocky Linux:8 | All versions | 0:0.14.3-4.el8 |
| `spice` | SUSE:HPE Helion OpenStack 8 | All versions | 0.12.8-18.1 |
| `spice` | SUSE:Linux Enterprise Micro 5.0 | All versions | 0.14.2-3.6.1 |
| `spice` | SUSE:Linux Enterprise Micro 5.2 | All versions | 0.14.3-150300.3.3.1 |
| `spice` | SUSE:Linux Enterprise Module for Server Applications 15 SP2 | All versions | 0.14.2-3.6.1 |
| `spice` | SUSE:Linux Enterprise Module for Server Applications 15 SP3 | All versions | 0.14.3-150300.3.3.1 |
| `spice` | SUSE:Linux Enterprise Server 12 SP3-BCL | All versions | 0.12.8-18.1 |
| `spice` | SUSE:Linux Enterprise Server 12 SP3-LTSS | All versions | 0.12.8-18.1 |
| `spice` | SUSE:Linux Enterprise Server 12 SP4-LTSS | All versions | 0.12.8-18.1 |
| `spice` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 0.12.8-18.1 |
| `spice` | SUSE:Linux Enterprise Server for SAP Applications 12 SP3 | All versions | 0.12.8-18.1 |
| `spice` | SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | All versions | 0.12.8-18.1 |
| `spice` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 0.12.8-18.1 |
| `spice` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 0.12.8-18.1 |
| `spice` | SUSE:OpenStack Cloud 8 | All versions | 0.12.8-18.1 |
| `spice` | SUSE:OpenStack Cloud 9 | All versions | 0.12.8-18.1 |
| `spice` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 0.12.8-18.1 |
| `spice` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 0.12.8-18.1 |
| `spice` | openSUSE:Leap 15.2 | All versions | 0.14.2-lp152.2.6.1 |
| `spice` | openSUSE:Leap 15.3 | All versions | 0.14.3-150300.3.3.1 |
| `spice` | openSUSE:Leap Micro 5.2 | All versions | 0.14.3-150300.3.3.1 |
| `spice` | openSUSE:Tumbleweed | All versions | 0.15.2-2.1 |
| `spice-gtk` | openSUSE:Tumbleweed | All versions | 0.41-3.1 |

Products: Redhat Enterprise Linux, Spice Project Spice.

## How do I fix CVE-2021-20201?

Upgrade to a fixed version.

## Is CVE-2021-20201 being exploited?

There is no known exploitation of CVE-2021-20201 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Enterprise Linux

- [CVE-2018-14667](https://insights.sbomify.com/CVE-2018-14667/): Red Hat JBoss RichFaces Framework Expression Language Injection (critical 9.8, exploited in the wild)
- [CVE-2021-20325](https://insights.sbomify.com/CVE-2021-20325/): Missing fixes for CVE-2021-40438 and CVE-2021-26691 in the versions of httpd, as shipped in Red Hat Enterprise Linux 8.5.0, causes a securit (critical 9.8)
- [CVE-2018-25011](https://insights.sbomify.com/CVE-2018-25011/): Memory corruption in libwebp (critical 9.8)
- [CVE-2018-25014](https://insights.sbomify.com/CVE-2018-25014/): Other in libwebp (critical 9.8)
- [CVE-2014-3585](https://insights.sbomify.com/CVE-2014-3585/): Supply chain in redhat-upgrade-tool (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-20201 and fix it if it is affected.

What it is: CVE-2021-20201 is a medium-severity denial of service vulnerability in Redhat Enterprise Linux, published on 28 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-20201 in the wild and no public exploit code.

Affected product: Redhat Enterprise Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-20201/ (Markdown: https://insights.sbomify.com/CVE-2021-20201/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-20201
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-20201
- OSV: https://osv.dev/vulnerability/CVE-2021-20201

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-20201/
Summaries are generated and may contain mistakes; the official description above is the record.
