{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2021-20208 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2021-20208 is a medium-severity vulnerability in Fedoraproject Fedora, published on 19 Apr 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-20208 and fix it if it is affected.\n\nWhat it is: CVE-2021-20208 is a medium-severity vulnerability in Fedoraproject Fedora, published on 19 Apr 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-20208 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-20208/ (Markdown: https://insights.sbomify.com/CVE-2021-20208/index.md)","id":"CVE-2021-20208","markdown":"https://insights.sbomify.com/CVE-2021-20208/index.md","name":"CVE-2021-20208","record":{"aliases":["ALPINE-CVE-2021-20208","AZL-6354","DEBIAN-CVE-2021-20208","GHSA-jx7v-8q27-738q","MGASA-2021-0277","OESA-2021-1193","SUSE-SU-2021:1159-1","SUSE-SU-2021:1161-1","UBUNTU-CVE-2021-20208"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["privilege_escalation","data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Linux CIFS utilities","requires_auth":"low_privilege","summary":"A container user can access host Kerberos credentials when mounting CIFS, leading to privilege escalation and data compromise.","user_interaction":"required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"enterprise_linux","vendor":"redhat"},{"product":"cifs-utils","vendor":"samba"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"},{"id":"CWE-266","name":"Incorrect Privilege Assignment"}],"description":"A flaw was found in cifs-utils in versions before 6.13. A user when mounting a krb5 CIFS file system from within a container can use Kerberos credentials of the host. The highest threat from this vulnerability is to data confidentiality and integrity.","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15 SP2","SUSE:Linux Enterprise Server 12 SP5","SUSE:Linux Enterprise Server for SAP Applications 12 SP5","SUSE:Linux Enterprise Software Development Kit 12 SP5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Privilege escalation in cifs-utils","id":"CVE-2021-20208","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora","redhat:enterprise_linux"],"type":"privilege_escalation","year":"2021"},"n_packages":4,"n_references":5,"next":{"headline":"Denial of service in privoxy","id":"CVE-2021-20209"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP2","fixed":["6.9-5.9.1"],"introduced":["0"],"last_affected":[],"package":"cifs-utils","purl":"pkg:rpm/suse/cifs-utils\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP2","source":"SUSE-SU-2021:1161-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5","fixed":["6.9-13.14.1"],"introduced":["0"],"last_affected":[],"package":"cifs-utils","purl":"pkg:rpm/suse/cifs-utils\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5","source":"SUSE-SU-2021:1159-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP5","fixed":["6.9-13.14.1"],"introduced":["0"],"last_affected":[],"package":"cifs-utils","purl":"pkg:rpm/suse/cifs-utils\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP5","source":"SUSE-SU-2021:1159-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP5","fixed":["6.9-13.14.1"],"introduced":["0"],"last_affected":[],"package":"cifs-utils","purl":"pkg:rpm/suse/cifs-utils\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP5","source":"SUSE-SU-2021:1159-1"}],"prev":{"headline":"containernetworking/cni improper limitation of path name","id":"CVE-2021-20206"},"products":["cifs-utils"],"published":"2021-04-19","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"A container user can access host Kerberos credentials when mounting CIFS, leading to privilege escalation and data compromise.","url":"https://insights.sbomify.com/CVE-2021-20208/"}