CVE-2021-20229 Incorrect Authorization in PostgreSQL
A user with SELECT privilege on one column can craft a query to read all columns of the table, bypassing column-level access controls.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-20229?
CVE-2021-20229 is a medium-severity missing authorization vulnerability in Fedoraproject Fedora, published on 23 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A flaw was found in PostgreSQL in versions before 13.2. This flaw allows a user with SELECT privilege on one column to craft a special query that returns all columns of the table. The highest threat from this vulnerability is to confidentiality.
Weakness: CWE-863
Which versions are affected by CVE-2021-20229?
1 open source package ship an affected version, including postgresql. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
postgresql Bitnami | From 13.0.0 | 13.2.0 |
Products include Fedoraproject Fedora, Postgresql Postgresql, Redhat Enterprise Linux, Redhat Software Collections.
How do I fix CVE-2021-20229?
Upgrade postgresql to 13.2.0 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-20229 being exploited?
There is no known exploitation of CVE-2021-20229 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as ALPINE-CVE-2021-20229, BIT-postgresql-2021-20229, CLEANSTART-2026-HC84403, DEBIAN-CVE-2021-20229, ECHO-5fd3-4f65-eae8, GHSA-43rr-wcj9-h45w and 1 more.