{"answers":{"affected":"1 open source package ship an affected version, including postgresql. It affects 4 products.","exploited":"There is no known exploitation of CVE-2021-20229 in the wild and no public exploit code.","fix":"Upgrade postgresql to 13.2.0 or later.","what":"CVE-2021-20229 is a medium-severity missing authorization vulnerability in Fedoraproject Fedora, published on 23 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-20229 and fix it if it is affected.\n\nWhat it is: CVE-2021-20229 is a medium-severity missing authorization vulnerability in Fedoraproject Fedora, published on 23 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-20229 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql (Bitnami): affected from 13.0.0; fixed in 13.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-20229/ (Markdown: https://insights.sbomify.com/CVE-2021-20229/index.md)","id":"CVE-2021-20229","markdown":"https://insights.sbomify.com/CVE-2021-20229/index.md","name":"CVE-2021-20229","record":{"aliases":["ALPINE-CVE-2021-20229","BIT-postgresql-2021-20229","CLEANSTART-2026-HC84403","DEBIAN-CVE-2021-20229","ECHO-5fd3-4f65-eae8","GHSA-43rr-wcj9-h45w","OESA-2021-1124"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL database","requires_auth":"low_privilege","summary":"A user with SELECT privilege on one column can craft a query to read all columns of the table, bypassing column-level access controls.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"postgresql","vendor":"postgresql"},{"product":"enterprise_linux","vendor":"redhat"},{"product":"software_collections","vendor":"redhat"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"A flaw was found in PostgreSQL in versions before 13.2. This flaw allows a user with SELECT privilege on one column to craft a special query that returns all columns of the table. The highest threat from this vulnerability is to confidentiality.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Incorrect Authorization in PostgreSQL","id":"CVE-2021-20229","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"fedoraproject:fedora","products":["fedoraproject:fedora","postgresql:postgresql","redhat:enterprise_linux","redhat:software_collections"],"type":"missing_authorization","year":"2021"},"n_packages":1,"n_references":3,"next":{"headline":"Auth bypass in stunnel","id":"CVE-2021-20230"},"packages":[{"ecosystem":"Bitnami","fixed":["13.2.0"],"introduced":["13.0.0"],"last_affected":[],"package":"postgresql","purl":"pkg:bitnami/postgresql","source":"BIT-postgresql-2021-20229"}],"prev":{"headline":"Ansible Exposes Sensitive Information","id":"CVE-2021-20228"},"products":["PostgreSQL"],"published":"2021-02-23","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"A user with SELECT privilege on one column can craft a query to read all columns of the table, bypassing column-level access controls.","url":"https://insights.sbomify.com/CVE-2021-20229/"}