# CVE-2021-20229: Incorrect Authorization in PostgreSQL

> A user with SELECT privilege on one column can craft a query to read all columns of the table, bypassing column-level access controls.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2021-20229, BIT-postgresql-2021-20229, CLEANSTART-2026-HC84403, DEBIAN-CVE-2021-20229, ECHO-5fd3-4f65-eae8, GHSA-43rr-wcj9-h45w, OESA-2021-1124

## What is CVE-2021-20229?

CVE-2021-20229 is a medium-severity missing authorization vulnerability in Fedoraproject Fedora, published on 23 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in PostgreSQL in versions before 13.2. This flaw allows a user with SELECT privilege on one column to craft a special query that returns all columns of the table. The highest threat from this vulnerability is to confidentiality.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2021-20229?

1 open source package ship an affected version, including postgresql. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | From 13.0.0 | 13.2.0 |

Products: Fedoraproject Fedora, Postgresql Postgresql, Redhat Enterprise Linux, Redhat Software Collections.

## How do I fix CVE-2021-20229?

Upgrade postgresql to 13.2.0 or later.

## Is CVE-2021-20229 being exploited?

There is no known exploitation of CVE-2021-20229 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-20229 and fix it if it is affected.

What it is: CVE-2021-20229 is a medium-severity missing authorization vulnerability in Fedoraproject Fedora, published on 23 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-20229 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected from 13.0.0; fixed in 13.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-20229/ (Markdown: https://insights.sbomify.com/CVE-2021-20229/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-20229
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-20229
- OSV: https://osv.dev/vulnerability/CVE-2021-20229

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-20229/
Summaries are generated and may contain mistakes; the official description above is the record.
