{"answers":{"affected":"2 open source packages ship an affected version, including foreman_fog_proxmox. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-20259 in the wild and no public exploit code.","fix":"Upgrade foreman_fog_proxmox to 0.13.1 or later.","what":"CVE-2021-20259 is a high-severity vulnerability in foreman, published on 7 Jun 2021. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-20259 and fix it if it is affected.\n\nWhat it is: CVE-2021-20259 is a high-severity vulnerability in foreman, published on 7 Jun 2021. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-20259 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- foreman_fog_proxmox (RubyGems): affected all versions; fixed in 0.13.1\n- foreman_fog_proxmox (RubyGems): affected all versions; fixed in 0.13.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-20259/ (Markdown: https://insights.sbomify.com/CVE-2021-20259/index.md)","id":"CVE-2021-20259","markdown":"https://insights.sbomify.com/CVE-2021-20259/index.md","name":"CVE-2021-20259","record":{"aliases":["GHSA-f2rp-4rv7-fc95"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Foreman Proxmox plugin","requires_auth":"low_privilege","summary":"An authenticated attacker with view_hosts permission can expose Proxmox passwords via the API, compromising confidentiality, integrity, and availability.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"foremanfogproxmox","vendor":"theforeman"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A flaw was found in the Foreman project. The Proxmox compute resource exposes the password through the API to an authenticated local attacker with view_hosts permission. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. Versions before foreman_fog_proxmox 0.13.1 are affected","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in foreman_fog_proxmox","id":"CVE-2021-20259","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"information_disclosure","year":"2021"},"n_packages":2,"n_references":1,"next":{"headline":"Information disclosure in foreman","id":"CVE-2021-20260"},"packages":[{"ecosystem":"RubyGems","fixed":["0.13.1"],"introduced":["0"],"last_affected":[],"package":"foreman_fog_proxmox","purl":null,"source":"GHSA-f2rp-4rv7-fc95"},{"ecosystem":"RubyGems","fixed":["0.13.1"],"introduced":["0"],"last_affected":[],"package":"foreman_fog_proxmox","purl":"pkg:gem/foreman_fog_proxmox","source":"GHSA-f2rp-4rv7-fc95"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2021-20258"},"products":["foreman"],"published":"2021-06-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"An authenticated attacker with view_hosts permission can expose Proxmox passwords via the API, compromising confidentiality, integrity, and availability.","url":"https://insights.sbomify.com/CVE-2021-20259/"}