# CVE-2021-20259: Exposure of Sensitive Information to an Unauthorized Actor in foreman_fog_proxmox

> An authenticated attacker with view_hosts permission can expose Proxmox passwords via the API, compromising confidentiality, integrity, and availability.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-f2rp-4rv7-fc95

## What is CVE-2021-20259?

CVE-2021-20259 is a high-severity vulnerability in foreman, published on 7 Jun 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A flaw was found in the Foreman project. The Proxmox compute resource exposes the password through the API to an authenticated local attacker with view_hosts permission. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. Versions before foreman_fog_proxmox 0.13.1 are affected

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-20259?

2 open source packages ship an affected version, including foreman_fog_proxmox. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `foreman_fog_proxmox` | RubyGems | All versions | 0.13.1 |
| `foreman_fog_proxmox` | RubyGems | All versions | 0.13.1 |

Products: Theforeman Foremanfogproxmox.

## How do I fix CVE-2021-20259?

Upgrade foreman_fog_proxmox to 0.13.1 or later.

## Is CVE-2021-20259 being exploited?

There is no known exploitation of CVE-2021-20259 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-20259 and fix it if it is affected.

What it is: CVE-2021-20259 is a high-severity vulnerability in foreman, published on 7 Jun 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-20259 in the wild and no public exploit code.

Affected packages and fixed versions:
- foreman_fog_proxmox (RubyGems): affected all versions; fixed in 0.13.1
- foreman_fog_proxmox (RubyGems): affected all versions; fixed in 0.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-20259/ (Markdown: https://insights.sbomify.com/CVE-2021-20259/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-20259
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-20259
- OSV: https://osv.dev/vulnerability/CVE-2021-20259

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-20259/
Summaries are generated and may contain mistakes; the official description above is the record.
