# CVE-2021-20267: Openstack Neutron has Insufficient Verification of IPv6 addresses

> Attackers can impersonate IPv6 addresses via crafted packets in Open vSwitch deployments, causing denial of service or traffic interception.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-20267, GHSA-w8hx-f868-pvch, PYSEC-2021-136, UBUNTU-CVE-2021-20267

## What is CVE-2021-20267?

CVE-2021-20267 is a high-severity vulnerability in openstack-neutron, published on 28 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in openstack-neutron's default Open vSwitch firewall rules. By sending carefully crafted packets, anyone in control of a server instance connected to the virtual switch can impersonate the IPv6 addresses of other systems on the network, resulting in denial of service or in some cases possibly interception of traffic intended for other destinations. Only deployments using the Open vSwitch driver are affected. Source: OpenStack project. Versions before openstack-neutron 15.3.3, openstack-neutron 16.3.1 and openstack-neutron 17.1.1 are affected.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2021-20267?

7 open source packages ship an affected version, including neutron. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `neutron` | PyPI | All versions | 15.3.3, 16.3.1, 17.1.1 |
| `neutron` | PyPI | All versions | 15.3.3 |
| `neutron` | PyPI | All versions | 15.3.3 |
| `neutron` | PyPI | From 16.0.0 | 16.3.1 |
| `neutron` | PyPI | From 16.0.0 | 16.3.1 |
| `neutron` | PyPI | From 17.0.0 | 17.1.1 |
| `neutron` | PyPI | From 17.0.0 | 17.1.1 |

Products: Openstack Neutron, Redhat Openstack Platform.

## How do I fix CVE-2021-20267?

Upgrade neutron to a fixed version for your release line: 15.3.3, 16.3.1 or 17.1.1.

## Is CVE-2021-20267 being exploited?

There is no known exploitation of CVE-2021-20267 in the wild and no public exploit code.

## Other vulnerabilities in openstack-neutron

- [CVE-2021-38598](https://insights.sbomify.com/CVE-2021-38598/): OpenStack Neutron vulnerable to hardware address impersonation (critical 9.1)
- [CVE-2015-8914](https://insights.sbomify.com/CVE-2015-8914/): OpenStack Neutron allows remote attackers to bypass an intended ICMPv6-spoofing protection mechanism (critical 9.1)
- [CVE-2016-5362](https://insights.sbomify.com/CVE-2016-5362/): OpenStack Neutron allows remote attackers to bypass an intended DHCP-spoofing protection mechanism (high 8.2)
- [CVE-2016-5363](https://insights.sbomify.com/CVE-2016-5363/): OpenStack Neutron Intended MAC-spoofing protection mechanism bypass (high 8.2)
- [CVE-2014-3632](https://insights.sbomify.com/CVE-2014-3632/): Privilege escalation in n/a (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-20267 and fix it if it is affected.

What it is: CVE-2021-20267 is a high-severity vulnerability in openstack-neutron, published on 28 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-20267 in the wild and no public exploit code.

Affected packages and fixed versions:
- neutron (PyPI): affected all versions; fixed in 15.3.3, 16.3.1, 17.1.1
- neutron (PyPI): affected all versions; fixed in 15.3.3
- neutron (PyPI): affected all versions; fixed in 15.3.3
- neutron (PyPI): affected from 16.0.0; fixed in 16.3.1
- neutron (PyPI): affected from 16.0.0; fixed in 16.3.1
- neutron (PyPI): affected from 17.0.0; fixed in 17.1.1
- neutron (PyPI): affected from 17.0.0; fixed in 17.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-20267/ (Markdown: https://insights.sbomify.com/CVE-2021-20267/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-20267
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-20267
- OSV: https://osv.dev/vulnerability/CVE-2021-20267

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-20267/
Summaries are generated and may contain mistakes; the official description above is the record.
