CVE-2021-20281 Moodle allowed some users without permission to view other users' full names
Unauthorized users can view other users' full names via the online users block in Moodle, exposing personal information.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-20281?
CVE-2021-20281 is a medium-severity missing authorization vulnerability in Fedoraproject Fedora, published on 15 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
It was possible for some users without permission to view other users' full names to do so via the online users block in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.
Which versions are affected by CVE-2021-20281?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10.0 | 3.10.2 |
moodle/moodle Packagist | From 3.10.0 | 3.10.2 |
moodle/moodle Packagist | From 3.5 | 3.5.17 |
moodle/moodle Packagist | From 3.5 | 3.5.17 |
moodle/moodle Packagist | From 3.8.0 | 3.8.8 |
moodle/moodle Packagist | From 3.8.0 | 3.8.8 |
3 more packages
moodle/moodle Packagist | From 3.9.0 | 3.9.5 |
moodle/moodle Packagist | From 3.9.0 | 3.9.5 |
moodle Bitnami | From 3.5.0 | 3.5.17, 3.8.8, 3.9.5, 3.10.2 |
Products include Fedoraproject Fedora, Moodle Moodle.
How do I fix CVE-2021-20281?
Upgrade moodle/moodle to a fixed version for your release line: 3.10.2, 3.5.17, 3.8.8 or 3.9.5.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-20281 being exploited?
There is no known exploitation of CVE-2021-20281 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as BIT-moodle-2021-20281, GHSA-93wh-35r4-6qmw, UBUNTU-CVE-2021-20281.