CVE-2021-20282 Moodle Bypass email verification secret when confirming account registration
Attackers can bypass email verification during account creation in Moodle, potentially leading to unauthorized account access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-20282?
CVE-2021-20282 is a medium-severity authentication bypass vulnerability in Fedoraproject Fedora, published on 15 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
When creating a user account, it was possible to verify the account without having access to the verification email link/secret in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.
Weakness: CWE-863
Which versions are affected by CVE-2021-20282?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10 | 3.10.2 |
moodle/moodle Packagist | From 3.10 | 3.10.2 |
moodle/moodle Packagist | From 3.5 | 3.5.17 |
moodle/moodle Packagist | From 3.5 | 3.5.17 |
moodle/moodle Packagist | From 3.8 | 3.8.8 |
moodle/moodle Packagist | From 3.8 | 3.8.8 |
3 more packages
moodle/moodle Packagist | From 3.9 | 3.9.5 |
moodle/moodle Packagist | From 3.9 | 3.9.5 |
moodle Bitnami | From 3.5.0 | 3.5.17, 3.8.8, 3.9.5, 3.10.2 |
Products include Fedoraproject Fedora, Moodle Moodle.
How do I fix CVE-2021-20282?
Upgrade moodle/moodle to a fixed version for your release line: 3.10.2, 3.5.17, 3.8.8 or 3.9.5.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2021-20282 being exploited?
There is no known exploitation of CVE-2021-20282 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as BIT-moodle-2021-20282, GHSA-grj4-g57c-9xmv, UBUNTU-CVE-2021-20282.