CVE-2021-20283 Missing permission check in Moodle
Attackers can view other users' enrolled courses without permission due to missing authorization checks in the web service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-20283?
CVE-2021-20283 is a medium-severity missing authorization vulnerability in Fedoraproject Fedora, published on 15 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The web service responsible for fetching other users' enrolled courses did not validate that the requesting user had permission to view that information in each course in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.
Which versions are affected by CVE-2021-20283?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.5.17 |
moodle/moodle Packagist | All versions | 3.5.17 |
moodle/moodle Packagist | From 3.10.0 | 3.10.2 |
moodle/moodle Packagist | From 3.10.0 | 3.10.2 |
moodle/moodle Packagist | From 3.8.0 | 3.8.8 |
moodle/moodle Packagist | From 3.8.0 | 3.8.8 |
3 more packages
moodle/moodle Packagist | From 3.9.0 | 3.9.5 |
moodle/moodle Packagist | From 3.9.0 | 3.9.5 |
moodle Bitnami | From 3.5.0 | 3.5.17, 3.8.8, 3.9.5, 3.10.2 |
Products include Fedoraproject Fedora, Moodle Moodle.
How do I fix CVE-2021-20283?
Upgrade moodle/moodle to a fixed version for your release line: 3.5.17, 3.10.2, 3.8.8 or 3.9.5.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-20283 being exploited?
There is no known exploitation of CVE-2021-20283 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as BIT-moodle-2021-20283, GHSA-2m72-m5cw-3g9h, UBUNTU-CVE-2021-20283.