# CVE-2021-20283: Missing permission check in Moodle

> Attackers can view other users' enrolled courses without permission due to missing authorization checks in the web service.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-moodle-2021-20283, GHSA-2m72-m5cw-3g9h, UBUNTU-CVE-2021-20283

## What is CVE-2021-20283?

CVE-2021-20283 is a medium-severity missing authorization vulnerability in Fedoraproject Fedora, published on 15 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The web service responsible for fetching other users' enrolled courses did not validate that the requesting user had permission to view that information in each course in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

Weakness: CWE-862 (Missing Authorization), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2021-20283?

9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | 3.5.17 |
| `moodle/moodle` | Packagist | All versions | 3.5.17 |
| `moodle/moodle` | Packagist | From 3.10.0 | 3.10.2 |
| `moodle/moodle` | Packagist | From 3.10.0 | 3.10.2 |
| `moodle/moodle` | Packagist | From 3.8.0 | 3.8.8 |
| `moodle/moodle` | Packagist | From 3.8.0 | 3.8.8 |
| `moodle/moodle` | Packagist | From 3.9.0 | 3.9.5 |
| `moodle/moodle` | Packagist | From 3.9.0 | 3.9.5 |
| `moodle` | Bitnami | From 3.5.0 | 3.5.17, 3.8.8, 3.9.5, 3.10.2 |

Products: Fedoraproject Fedora, Moodle Moodle.

## How do I fix CVE-2021-20283?

Upgrade moodle/moodle to a fixed version for your release line: 3.5.17, 3.10.2, 3.8.8 or 3.9.5.

## Is CVE-2021-20283 being exploited?

There is no known exploitation of CVE-2021-20283 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-20283 and fix it if it is affected.

What it is: CVE-2021-20283 is a medium-severity missing authorization vulnerability in Fedoraproject Fedora, published on 15 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-20283 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; fixed in 3.5.17
- moodle/moodle (Packagist): affected all versions; fixed in 3.5.17
- moodle/moodle (Packagist): affected from 3.10.0; fixed in 3.10.2
- moodle/moodle (Packagist): affected from 3.10.0; fixed in 3.10.2
- moodle/moodle (Packagist): affected from 3.8.0; fixed in 3.8.8
- moodle/moodle (Packagist): affected from 3.8.0; fixed in 3.8.8
- moodle/moodle (Packagist): affected from 3.9.0; fixed in 3.9.5
- moodle/moodle (Packagist): affected from 3.9.0; fixed in 3.9.5
- moodle (Bitnami): affected from 3.5.0; fixed in 3.5.17, 3.8.8, 3.9.5, 3.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-20283/ (Markdown: https://insights.sbomify.com/CVE-2021-20283/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-20283
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-20283
- OSV: https://osv.dev/vulnerability/CVE-2021-20283

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-20283/
Summaries are generated and may contain mistakes; the official description above is the record.
