# CVE-2021-20289: Exposure of class information in RESTEasy

> Attackers can obtain internal endpoint class and method names via exception responses when parameter conversion fails, exposing sensitive application structure details.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-244r-fcj3-ghjq, OESA-2021-1171, UBUNTU-CVE-2021-20289

## What is CVE-2021-20289?

CVE-2021-20289 is a medium-severity vulnerability in Netapp Oncommand Insight, published on 26 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in RESTEasy in all versions of RESTEasy up to 4.6.0.Final. The endpoint class and method names are returned as part of the exception response when RESTEasy cannot convert one of the request URI path or query values to the matching JAX-RS resource method's parameter value. The highest threat from this vulnerability is to data confidentiality.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2021-20289?

6 open source packages ship an affected version, including org.jboss.resteasy:resteasy-core. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jboss.resteasy:resteasy-core` | Maven | From 3.0.0 | 3.16.0 |
| `org.jboss.resteasy:resteasy-core` | Maven | From 3.0.0 | 3.16.0 |
| `org.jboss.resteasy:resteasy-core` | Maven | From 4.0.0 | 4.5.10 |
| `org.jboss.resteasy:resteasy-core` | Maven | From 4.0.0 | 4.5.10 |
| `org.jboss.resteasy:resteasy-core` | Maven | From 4.6.0 | 4.6.1 |
| `org.jboss.resteasy:resteasy-core` | Maven | From 4.6.0 | 4.6.1 |

Products: Netapp Oncommand Insight, Oracle Communications Cloud Native Core Console, Quarkus Quarkus, Redhat Resteasy.

## How do I fix CVE-2021-20289?

Upgrade org.jboss.resteasy:resteasy-core to a fixed version for your release line: 3.16.0, 4.5.10 or 4.6.1.

## Is CVE-2021-20289 being exploited?

There is no known exploitation of CVE-2021-20289 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Oncommand Insight

- [CVE-2017-5600](https://insights.sbomify.com/CVE-2017-5600/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2018-1258](https://insights.sbomify.com/CVE-2018-1258/): Spring Framework when used in combination with any versions of Spring Security contains an authorization bypass (high 8.8)
- [CVE-2020-5421](https://insights.sbomify.com/CVE-2020-5421/): RFD Protection Bypass via jsessionid (high 8.7)
- [CVE-2022-38733](https://insights.sbomify.com/CVE-2022-38733/): Auth bypass in OnCommand Insight (high 8.6)
- [CVE-2023-22102](https://insights.sbomify.com/CVE-2023-22102/): MySQL Connectors takeover vulnerability (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-20289 and fix it if it is affected.

What it is: CVE-2021-20289 is a medium-severity vulnerability in Netapp Oncommand Insight, published on 26 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-20289 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jboss.resteasy:resteasy-core (Maven): affected from 3.0.0; fixed in 3.16.0
- org.jboss.resteasy:resteasy-core (Maven): affected from 3.0.0; fixed in 3.16.0
- org.jboss.resteasy:resteasy-core (Maven): affected from 4.0.0; fixed in 4.5.10
- org.jboss.resteasy:resteasy-core (Maven): affected from 4.0.0; fixed in 4.5.10
- org.jboss.resteasy:resteasy-core (Maven): affected from 4.6.0; fixed in 4.6.1
- org.jboss.resteasy:resteasy-core (Maven): affected from 4.6.0; fixed in 4.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-20289/ (Markdown: https://insights.sbomify.com/CVE-2021-20289/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-20289
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-20289
- OSV: https://osv.dev/vulnerability/CVE-2021-20289

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-20289/
Summaries are generated and may contain mistakes; the official description above is the record.
