{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2021-20314 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2021-20314 is a critical memory corruption vulnerability in Fedoraproject Fedora, published on 12 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-20314 and fix it if it is affected.\n\nWhat it is: CVE-2021-20314 is a critical memory corruption vulnerability in Fedoraproject Fedora, published on 12 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-20314 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-20314/ (Markdown: https://insights.sbomify.com/CVE-2021-20314/index.md)","id":"CVE-2021-20314","markdown":"https://insights.sbomify.com/CVE-2021-20314/index.md","name":"CVE-2021-20314","record":{"aliases":["ALPINE-CVE-2021-20314","DEBIAN-CVE-2021-20314","DLA-2739-1","DSA-4955-1","GHSA-7mf9-xf4j-h63m","MGASA-2021-0414","MGASA-2021-0454","UBUNTU-CVE-2021-20314","openSUSE-SU-2021:1187-1","openSUSE-SU-2024:10995-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"SPF library","requires_auth":"none","summary":"A stack buffer overflow in libspf2 allows attackers to cause denial of service or execute code via crafted SPF messages.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"libspf2","vendor":"libspf2"},{"product":"enterprise_linux","vendor":"redhat"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"Stack buffer overflow in libspf2 versions below 1.2.11 when processing certain SPF macros can lead to Denial of service and potentially code execution via malicious crafted SPF explanation messages.","ecosystems":["SUSE:Package Hub 15 SP1","SUSE:Package Hub 15 SP2","SUSE:Package Hub 15 SP3","openSUSE:Leap 15.2","openSUSE:Leap 15.3","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in libspf2","id":"CVE-2021-20314","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora","redhat:enterprise_linux"],"type":"memory_corruption","year":"2021"},"n_packages":6,"n_references":5,"next":{"headline":"Security feature bypass in gnome-shell","id":"CVE-2021-20315"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP1","fixed":["1.2.10-bp153.5.1"],"introduced":["0"],"last_affected":[],"package":"libspf2","purl":"pkg:rpm/suse/libspf2\u0026distro=SUSE%20Package%20Hub%2015%20SP1","source":"openSUSE-SU-2021:1187-1"},{"ecosystem":"SUSE:Package Hub 15 SP2","fixed":["1.2.10-bp153.5.1"],"introduced":["0"],"last_affected":[],"package":"libspf2","purl":"pkg:rpm/suse/libspf2\u0026distro=SUSE%20Package%20Hub%2015%20SP2","source":"openSUSE-SU-2021:1187-1"},{"ecosystem":"SUSE:Package Hub 15 SP3","fixed":["1.2.10-bp153.5.1"],"introduced":["0"],"last_affected":[],"package":"libspf2","purl":"pkg:rpm/suse/libspf2\u0026distro=SUSE%20Package%20Hub%2015%20SP3","source":"openSUSE-SU-2021:1187-1"},{"ecosystem":"openSUSE:Leap 15.2","fixed":["1.2.10-bp153.5.1"],"introduced":["0"],"last_affected":[],"package":"libspf2","purl":"pkg:rpm/opensuse/libspf2\u0026distro=openSUSE%20Leap%2015.2","source":"openSUSE-SU-2021:1187-1"},{"ecosystem":"openSUSE:Leap 15.3","fixed":["1.2.10-bp153.5.1"],"introduced":["0"],"last_affected":[],"package":"libspf2","purl":"pkg:rpm/opensuse/libspf2\u0026distro=openSUSE%20Leap%2015.3","source":"openSUSE-SU-2021:1187-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.01-5.3"],"introduced":["0"],"last_affected":[],"package":"libspf2","purl":"pkg:rpm/opensuse/libspf2\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10995-1"}],"prev":{"headline":"Information disclosure in ImageMagick","id":"CVE-2021-20313"},"products":["libspf2"],"published":"2021-08-12","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-02-13","vendors":["n/a"]},"summary":"A stack buffer overflow in libspf2 allows attackers to cause denial of service or execute code via crafted SPF messages.","url":"https://insights.sbomify.com/CVE-2021-20314/"}