CVE-2021-20330 Specific replication command with malformed oplog entries can crash secondaries

Medium 6.5 Published Updated

An attacker with basic CRUD permissions can crash secondary database nodes by sending malformed oplog entries via the applyOps command.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-20330?

CVE-2021-20330 is a medium-severity denial of service vulnerability in Mongodb Mongodb, published on 15 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An attacker with basic CRUD permissions on a replicated collection can run the applyOps command with specially malformed oplog entries, resulting in a potential denial of service on secondaries. This issue affects MongoDB Server v4.0 versions prior to 4.0.27; MongoDB Server v4.2 versions prior to 4.2.16; MongoDB Server v4.4 versions prior to 4.4.9.

Weakness: CWE-20

Which versions are affected by CVE-2021-20330?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 4.0.04.0.25, 4.2.14, 4.4.6

Products include Mongodb Mongodb.

How do I fix CVE-2021-20330?

Upgrade mongodb to a fixed version for your release line: 4.0.25, 4.2.14 or 4.4.6.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-20330 being exploited?

There is no known exploitation of CVE-2021-20330 in the wild and no public exploit code.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2021-20330, GHSA-8jvf-jqg4-r6h2.

Is CVE-2021-20330 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free