# CVE-2021-20330: Specific replication command with malformed oplog entries can crash secondaries

> An attacker with basic CRUD permissions can crash secondary database nodes by sending malformed oplog entries via the applyOps command.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Dec 2021
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-mongodb-2021-20330, GHSA-8jvf-jqg4-r6h2

## What is CVE-2021-20330?

CVE-2021-20330 is a medium-severity denial of service vulnerability in Mongodb Mongodb, published on 15 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An attacker with basic CRUD permissions on a replicated collection can run the applyOps command with specially malformed oplog entries, resulting in a potential denial of service on secondaries. This issue affects MongoDB Server v4.0 versions prior to 4.0.27; MongoDB Server v4.2 versions prior to 4.2.16; MongoDB Server v4.4 versions prior to 4.4.9.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-20330?

1 open source package ship an affected version, including mongodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb` | Bitnami | From 4.0.0 | 4.0.25, 4.2.14, 4.4.6 |

Products: Mongodb Mongodb.

## How do I fix CVE-2021-20330?

Upgrade mongodb to a fixed version for your release line: 4.0.25, 4.2.14 or 4.4.6.

## Is CVE-2021-20330 being exploited?

There is no known exploitation of CVE-2021-20330 in the wild and no public exploit code.

## Other vulnerabilities in Mongodb Mongodb

- [CVE-2025-14847](https://insights.sbomify.com/CVE-2025-14847/): MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency (high 8.7, exploited in the wild)
- [CVE-2026-82067](https://insights.sbomify.com/CVE-2026-82067/): Auth bypass in MongoDB Server (critical 9.2)
- [CVE-2026-13072](https://insights.sbomify.com/CVE-2026-13072/): MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption (critical 9.2)
- [CVE-2017-15535](https://insights.sbomify.com/CVE-2017-15535/): Denial of service in n/a (critical 9.1)
- [CVE-2026-18691](https://insights.sbomify.com/CVE-2026-18691/): Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-20330 and fix it if it is affected.

What it is: CVE-2021-20330 is a medium-severity denial of service vulnerability in Mongodb Mongodb, published on 15 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-20330 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongodb (Bitnami): affected from 4.0.0; fixed in 4.0.25, 4.2.14, 4.4.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-20330/ (Markdown: https://insights.sbomify.com/CVE-2021-20330/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-20330
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-20330
- OSV: https://osv.dev/vulnerability/CVE-2021-20330

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-20330/
Summaries are generated and may contain mistakes; the official description above is the record.
