# CVE-2021-20654: Cross-site scripting in Wekan

> Attackers can inject malicious scripts into Wekan kanban boards, potentially stealing user sessions or executing code in victim browsers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 10 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-p4j3-3c38-6j6r

## What is CVE-2021-20654?

CVE-2021-20654 is a medium-severity cross-site scripting vulnerability in Wekan, published on 10 Feb 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Wekan, open source kanban board system, between version 3.12 and 4.11, is vulnerable to multiple stored cross-site scripting. This is named 'Fieldbleed' in the vendor's site.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-20654?

It affects 1 product.


Products: Wekan Project Wekan.

## How do I fix CVE-2021-20654?

No fix has been published for CVE-2021-20654 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-20654 being exploited?

There is no known exploitation of CVE-2021-20654 in the wild and no public exploit code.

## Other vulnerabilities in Wekan

- [CVE-2026-30843](https://insights.sbomify.com/CVE-2026-30843/): Wekan has Cross-Board IDOR in Custom Fields Update Endpoints (critical 9.3)
- [CVE-2026-30844](https://insights.sbomify.com/CVE-2026-30844/): Wekan Vulnerable to SSRF through Lack of Validation or Filtering in Attachment URL Loading (critical 9.3)
- [CVE-2026-30847](https://insights.sbomify.com/CVE-2026-30847/): Wekan Credential Leak via notificationUsers Publication Exposes Password Hashes and Session Tokens (critical 9.3)
- [CVE-2025-65780](https://insights.sbomify.com/CVE-2025-65780/): Missing authorization in n/a (high 8.8)
- [CVE-2026-30846](https://insights.sbomify.com/CVE-2026-30846/): Wekan Exposes All Global Webhook Integrations through globalwebhooks Publication (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-20654 and fix it if it is affected.

What it is: CVE-2021-20654 is a medium-severity cross-site scripting vulnerability in Wekan, published on 10 Feb 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-20654 in the wild and no public exploit code.

Affected product: Wekan. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-20654/ (Markdown: https://insights.sbomify.com/CVE-2021-20654/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-20654
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-20654
- OSV: https://osv.dev/vulnerability/CVE-2021-20654

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-20654/
Summaries are generated and may contain mistakes; the official description above is the record.
