{"answers":{"affected":"2 open source packages ship an affected version, including ec-cube/ec-cube. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-20751 in the wild and no public exploit code.","fix":"Upgrade ec-cube/ec-cube to 4.0.6 or later.","what":"CVE-2021-20751 is a medium-severity cross-site scripting vulnerability in EC-CUBE, published on 28 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-20751 and fix it if it is affected.\n\nWhat it is: CVE-2021-20751 is a medium-severity cross-site scripting vulnerability in EC-CUBE, published on 28 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-20751 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ec-cube/ec-cube (Packagist): affected from 4.0.0; fixed in 4.0.6\n- ec-cube/ec-cube (Packagist): affected from 4.0.0; fixed in 4.0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-20751/ (Markdown: https://insights.sbomify.com/CVE-2021-20751/index.md)","id":"CVE-2021-20751","markdown":"https://insights.sbomify.com/CVE-2021-20751/index.md","name":"CVE-2021-20751","record":{"aliases":["GHSA-r6qq-qc9m-98w2"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"EC-CUBE e-commerce platform","requires_auth":"none","summary":"Remote attackers can inject arbitrary scripts into EC-CUBE, potentially compromising administrator or user accounts via crafted pages.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[{"product":"ec-cube","vendor":"ec-cube"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting vulnerability in EC-CUBE EC-CUBE 4.0.0 to 4.0.5-p1 (EC-CUBE 4 series) allows a remote attacker to inject an arbitrary script by leading an administrator or a user to a specially crafted page and to perform a specific operation.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"EC-CUBE Cross-site scripting vulnerability","id":"CVE-2021-20751","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site scripting in IkaIka RSS Reader","id":"CVE-2021-20752"},"packages":[{"ecosystem":"Packagist","fixed":["4.0.6"],"introduced":["4.0.0"],"last_affected":[],"package":"ec-cube/ec-cube","purl":null,"source":"GHSA-r6qq-qc9m-98w2"},{"ecosystem":"Packagist","fixed":["4.0.6"],"introduced":["4.0.0"],"last_affected":[],"package":"ec-cube/ec-cube","purl":"pkg:composer/ec-cube/ec-cube","source":"GHSA-r6qq-qc9m-98w2"}],"prev":{"headline":"EC-CUBE Cross-site scripting vulnerability","id":"CVE-2021-20750"},"products":["EC-CUBE"],"published":"2021-06-28","related":[{"cvss_score":8.1,"headline":"EC-CUBE Directory traversal vulnerability","id":"CVE-2020-5590","kev_date_added":null,"published":"2020-06-19"},{"cvss_score":7.5,"headline":"Missing authorization in EC-CUBE","id":"CVE-2021-20778","kev_date_added":null,"published":"2021-07-01"},{"cvss_score":7.5,"headline":"EC-CUBE Improper input validation vulnerability","id":"CVE-2020-5680","kev_date_added":null,"published":"2020-12-03"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2008-4991","kev_date_added":null,"published":"2008-11-06"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2008-4534","kev_date_added":null,"published":"2008-10-10"},{"cvss_score":7.2,"headline":"Code injection in EC-CUBE 3 series","id":"CVE-2023-46845","kev_date_added":null,"published":"2023-11-07"},{"cvss_score":6.9,"headline":"Auth bypass in EC-CUBE 4.1 series","id":"CVE-2026-30777","kev_date_added":null,"published":"2026-03-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["EC-CUBE CO.,LTD."]},"summary":"Remote attackers can inject arbitrary scripts into EC-CUBE, potentially compromising administrator or user accounts via crafted pages.","url":"https://insights.sbomify.com/CVE-2021-20751/"}