# CVE-2021-20848: Cross-site Scripting in github.com/schollz/rwtxt

> A remote attacker can inject arbitrary scripts into rwtxt, potentially leading to code execution or account takeover.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Nov 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-458f-26r3-x2c3, GO-2022-0231

## What is CVE-2021-20848?

CVE-2021-20848 is a medium-severity cross-site scripting vulnerability in Zack Scholl rwtxt, published on 24 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting vulnerability in rwtxt versions prior to v1.8.6 allows a remote attacker to inject an arbitrary script via unspecified vectors.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-20848?

3 open source packages ship an affected version, including github.com/schollz/rwtxt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/schollz/rwtxt` | Go | All versions | 1.8.6 |
| `github.com/schollz/rwtxt` | Go | All versions | 1.8.6 |
| `github.com/schollz/rwtxt` | Go | All versions | 1.8.6 |

Products: Rwtxt Project Rwtxt.

## How do I fix CVE-2021-20848?

Upgrade github.com/schollz/rwtxt to 1.8.6 or later.

## Is CVE-2021-20848 being exploited?

There is no known exploitation of CVE-2021-20848 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-20848 and fix it if it is affected.

What it is: CVE-2021-20848 is a medium-severity cross-site scripting vulnerability in Zack Scholl rwtxt, published on 24 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-20848 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/schollz/rwtxt (Go): affected all versions; fixed in 1.8.6
- github.com/schollz/rwtxt (Go): affected all versions; fixed in 1.8.6
- github.com/schollz/rwtxt (Go): affected all versions; fixed in 1.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-20848/ (Markdown: https://insights.sbomify.com/CVE-2021-20848/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-20848
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-20848
- OSV: https://osv.dev/vulnerability/CVE-2021-20848

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-20848/
Summaries are generated and may contain mistakes; the official description above is the record.
