# CVE-2021-21014: Magento Commerce Arbitrary Folder Empty Could Lead To Arbitrary Code Execution

> An authenticated attacker with admin access can bypass file upload restrictions to execute arbitrary code on Magento Commerce.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Feb 2021
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-magento-2021-21014, GHSA-269w-pqc7-68q9

## What is CVE-2021-21014?

CVE-2021-21014 is a critical vulnerability in Magento Magento, published on 11 Feb 2021. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are vulnerable to a file upload restriction bypass. Successful exploitation could lead to arbitrary code execution by an authenticated attacker. Access to the admin console is required for successful exploitation.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2021-21014?

7 open source packages ship an affected version, including magento/community-edition, magento and magento/project-community-edition. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | All versions | 2.3.6-p1 |
| `magento/community-edition` | Packagist | All versions | 2.3.6-p1 |
| `magento/community-edition` | Packagist | From 2.4.0 | 2.4.2 |
| `magento/community-edition` | Packagist | From 2.4.0 | 2.4.2 |
| `magento` | Bitnami | All versions | 2.3.6, 2.4.2 |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |

Products: Magento Magento.

## How do I fix CVE-2021-21014?

Upgrade magento/community-edition to a fixed version for your release line: 2.3.6-p1 or 2.4.2.

## Is CVE-2021-21014 being exploited?

There is no known exploitation of CVE-2021-21014 in the wild and no public exploit code.

Public exploit code:

- Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are vulnerable to a file upload restriction bypass. Successful exploitation could lead to arbitrary code execution by an authenticated attacker. (github_poc): https://github.com/HoangKien1020/CVE-2021-21014

## Other vulnerabilities in Magento Magento

- [CVE-2020-9664](https://insights.sbomify.com/CVE-2020-9664/): Magento php object injection vulnerability (critical 9.8)
- [CVE-2020-9576](https://insights.sbomify.com/CVE-2020-9576/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9578](https://insights.sbomify.com/CVE-2020-9578/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9579](https://insights.sbomify.com/CVE-2020-9579/): Magento Security mitigation bypass vulnerability (critical 9.8)
- [CVE-2020-9580](https://insights.sbomify.com/CVE-2020-9580/): Magento Security mitigation bypass vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21014 and fix it if it is affected.

What it is: CVE-2021-21014 is a critical vulnerability in Magento Magento, published on 11 Feb 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21014 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected all versions; fixed in 2.3.6-p1
- magento/community-edition (Packagist): affected all versions; fixed in 2.3.6-p1
- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.2
- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.2
- magento (Bitnami): affected all versions; fixed in 2.3.6, 2.4.2
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21014/ (Markdown: https://insights.sbomify.com/CVE-2021-21014/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21014
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21014
- OSV: https://osv.dev/vulnerability/CVE-2021-21014

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21014/
Summaries are generated and may contain mistakes; the official description above is the record.
