CVE-2021-21016 Magento Commerce Unauthorized Data Modification Could Lead to Arbitrary Code Execution
Authenticated attackers can execute arbitrary OS commands via WebAPI in Magento Commerce, leading to remote code execution.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-21016?
CVE-2021-21016 is a critical command injection vulnerability in Magento Magento, published on 11 Feb 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are vulnerable to OS command injection via the WebAPI. Successful exploitation could lead to remote code execution by an authenticated attacker. Access to the admin console is required for successful exploitation.
Weakness: CWE-78
Which versions are affected by CVE-2021-21016?
7 open source packages ship an affected version, including magento/community-edition, magento and magento/project-community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | 2.3.6-p1 |
magento/community-edition Packagist | All versions | 2.3.6-p1 |
magento/community-edition Packagist | From 2.4.0 | 2.4.2 |
magento/community-edition Packagist | From 2.4.0 | 2.4.2 |
magento Bitnami | All versions | 2.3.6, 2.4.2 |
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
1 more packages
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
Products include Magento Magento.
How do I fix CVE-2021-21016?
Upgrade magento/community-edition to a fixed version for your release line: 2.3.6-p1 or 2.4.2.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2021-21016 being exploited?
There is no known exploitation of CVE-2021-21016 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as BIT-magento-2021-21016, GHSA-792f-c8mp-2cr5.