CVE-2021-21019 Magento Commerce XML Injection Could Lead To Remote Code Execution
An authenticated attacker with admin access can exploit XML injection in the Widgets module to achieve arbitrary code execution.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-21019?
CVE-2021-21019 is a critical vulnerability in Magento Magento, published on 11 Feb 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are vulnerable to XML injection in the Widgets module. Successful exploitation could lead to arbitrary code execution by an authenticated attacker. Access to the admin console is required for successful exploitation.
Weakness: CWE-91
Which versions are affected by CVE-2021-21019?
5 open source packages ship an affected version, including magento/community-edition and magento. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | 2.3.6-p1 |
magento/community-edition Packagist | All versions | 2.3.6-p1 |
magento/community-edition Packagist | From 2.4.0 | 2.4.1-p1 |
magento/community-edition Packagist | From 2.4.0 | 2.4.1-p1 |
magento Bitnami | All versions | 2.3.6, 2.4.2 |
Products include Magento Magento.
How do I fix CVE-2021-21019?
Upgrade magento/community-edition to a fixed version for your release line: 2.3.6-p1 or 2.4.1-p1.
Is CVE-2021-21019 being exploited?
There is no known exploitation of CVE-2021-21019 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as BIT-magento-2021-21019, GHSA-mw95-gmw4-883p.