CVE-2021-21023 Magento Commerce Stored Cross Site Scripting Vulnerability Could Lead To Arbitrary Code Execution
Stored XSS in Magento admin console allows arbitrary JavaScript execution, potentially leading to account takeover or code execution.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-21023?
CVE-2021-21023 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 11 Feb 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are vulnerable to a stored cross-site scripting vulnerability in the admin console. Successful exploitation could lead to arbitrary JavaScript execution in the victim's browser. Access to the admin console is required for successful exploitation.
Weakness: CWE-79
Which versions are affected by CVE-2021-21023?
7 open source packages ship an affected version, including magento/community-edition, magento and magento/project-community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | 2.3.6 |
magento/community-edition Packagist | All versions | 2.3.6 |
magento/community-edition Packagist | From 2.4.0 | 2.4.1-p1 |
magento/community-edition Packagist | From 2.4.0 | 2.4.1-p1 |
magento Bitnami | All versions | 2.3.6, 2.4.1 |
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
1 more packages
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
Products include Magento Magento.
How do I fix CVE-2021-21023?
Upgrade magento/community-edition to a fixed version for your release line: 2.3.6 or 2.4.1-p1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-21023 being exploited?
There is no known exploitation of CVE-2021-21023 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as BIT-magento-2021-21023, GHSA-h5rm-m772-6qcx.