{"answers":{"affected":"7 open source packages ship an affected version, including magento/community-edition, magento and magento/project-community-edition. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21026 in the wild and no public exploit code.","fix":"Upgrade magento/community-edition to a fixed version for your release line: 2.3.6-p1 or 2.4.2.","what":"CVE-2021-21026 is a medium-severity missing authorization vulnerability in Magento Magento, published on 11 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21026 and fix it if it is affected.\n\nWhat it is: CVE-2021-21026 is a medium-severity missing authorization vulnerability in Magento Magento, published on 11 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21026 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- magento/community-edition (Packagist): affected all versions; fixed in 2.3.6-p1\n- magento/community-edition (Packagist): affected all versions; fixed in 2.3.6-p1\n- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.2\n- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.2\n- magento (Bitnami): affected all versions; fixed in 2.3.6, 2.4.1\n- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed\n- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21026/ (Markdown: https://insights.sbomify.com/CVE-2021-21026/index.md)","id":"CVE-2021-21026","markdown":"https://insights.sbomify.com/CVE-2021-21026/index.md","name":"CVE-2021-21026","record":{"aliases":["BIT-magento-2021-21026","GHSA-crjc-2v9m-8w7r"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Magento Commerce","requires_auth":"low_privilege","summary":"An authenticated admin can exploit improper authorization in the integrations module to gain unauthorized access to restricted resources.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"adobe","cpe":[{"product":"magento","vendor":"magento"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"}],"description":"Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are affected by an improper authorization vulnerability in the integrations module. Successful exploitation could lead to unauthorized access to restricted resources by an unauthenticated attacker. Access to the admin console is required for successful exploitation.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Magento Commerce Incorrect permissions Could Lead To Unauthorized Access","id":"CVE-2021-21026","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"magento:magento","products":["magento:magento"],"type":"missing_authorization","year":"2021"},"n_packages":7,"n_references":1,"next":{"headline":"Magento Commerce Cross-Site Request Forgery (CSRF) Could Lead To Unauthorized Data Modification","id":"CVE-2021-21027"},"packages":[{"ecosystem":"Bitnami","fixed":["2.3.6","2.4.1"],"introduced":["0","2.4.0"],"last_affected":[],"package":"magento","purl":"pkg:bitnami/magento","source":"BIT-magento-2021-21026"},{"ecosystem":"Packagist","fixed":["2.3.6-p1"],"introduced":["0"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-crjc-2v9m-8w7r"},{"ecosystem":"Packagist","fixed":["2.3.6-p1"],"introduced":["0"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-crjc-2v9m-8w7r"},{"ecosystem":"Packagist","fixed":["2.4.2"],"introduced":["2.4.0"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-crjc-2v9m-8w7r"},{"ecosystem":"Packagist","fixed":["2.4.2"],"introduced":["2.4.0"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-crjc-2v9m-8w7r"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["2.0.2"],"package":"magento/project-community-edition","purl":null,"source":"GHSA-crjc-2v9m-8w7r"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["2.0.2"],"package":"magento/project-community-edition","purl":"pkg:composer/magento/project-community-edition","source":"GHSA-crjc-2v9m-8w7r"}],"prev":{"headline":"Magento Commerce XML Injection Could Lead To Arbitrary Code Execution","id":"CVE-2021-21025"},"products":["Magento Commerce"],"published":"2021-02-11","related":[{"cvss_score":9.8,"headline":"Magento php object injection vulnerability","id":"CVE-2020-9664","kev_date_added":null,"published":"2020-07-22"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9576","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9578","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9579","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9580","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9582","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9583","kev_date_added":null,"published":"2020-06-26"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Adobe"]},"summary":"An authenticated admin can exploit improper authorization in the integrations module to gain unauthorized access to restricted resources.","url":"https://insights.sbomify.com/CVE-2021-21026/"}