CVE-2021-21027 Magento Commerce Cross-Site Request Forgery (CSRF) Could Lead To Unauthorized Data Modification
An unauthenticated attacker can exploit a CSRF vulnerability in the GraphQL API to modify customer metadata without admin access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-21027?
CVE-2021-21027 is a medium-severity vulnerability in Magento Magento, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are affected by a cross-site request forgery (CSRF) vulnerability via the GraphQL API. Successful exploitation could lead to unauthorized modification of customer metadata by an unauthenticated attacker. Access to the admin console is not required for successful exploitation.
Weakness: CWE-352
Which versions are affected by CVE-2021-21027?
7 open source packages ship an affected version, including magento/community-edition, magento and magento/project-community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | 2.3.6-p1 |
magento/community-edition Packagist | All versions | 2.3.6-p1 |
magento/community-edition Packagist | From 2.4.0 | 2.4.2 |
magento/community-edition Packagist | From 2.4.0 | 2.4.2 |
magento Bitnami | All versions | 2.3.6, 2.4.1 |
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
1 more packages
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
Products include Magento Magento.
How do I fix CVE-2021-21027?
Upgrade magento/community-edition to a fixed version for your release line: 2.3.6-p1 or 2.4.2.
Is CVE-2021-21027 being exploited?
There is no known exploitation of CVE-2021-21027 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as BIT-magento-2021-21027, GHSA-h4xc-577p-hgj9.