CVE-2021-21029 Magento Commerce Reflected Cross-site Scripting Vulnerability Could Lead To Arbitrary JavaScript Execution

Medium 4.8 Published Updated

Reflected XSS in Magento Commerce allows arbitrary JavaScript execution in the victim's browser, requiring admin console access for exploitation.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-21029?

CVE-2021-21029 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 11 Feb 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are affected by a Reflected Cross-site Scripting vulnerability via 'file' parameter. Successful exploitation could lead to arbitrary JavaScript execution in the victim's browser. Access to the admin console is required for successful exploitation.

Weakness: CWE-79

Which versions are affected by CVE-2021-21029?

5 open source packages ship an affected version, including magento/community-edition and magento. It affects 1 product.

PackageAffectedFixed in
magento/community-edition PackagistAll versions2.3.6-p1
magento/community-edition PackagistAll versions2.3.6-p1
magento/community-edition PackagistFrom 2.4.02.4.2
magento/community-edition PackagistFrom 2.4.02.4.2
magento BitnamiAll versions2.3.6, 2.4.1

Products include Magento Magento.

How do I fix CVE-2021-21029?

Upgrade magento/community-edition to a fixed version for your release line: 2.3.6-p1 or 2.4.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-21029 being exploited?

There is no known exploitation of CVE-2021-21029 in the wild and no public exploit code.

All Magento Magento vulnerabilities

Sources

Also known as BIT-magento-2021-21029, GHSA-jwxh-wj79-ccm6.

Is CVE-2021-21029 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free