{"answers":{"affected":"5 open source packages ship an affected version, including magento/community-edition and magento. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21029 in the wild and no public exploit code.","fix":"Upgrade magento/community-edition to a fixed version for your release line: 2.3.6-p1 or 2.4.2.","what":"CVE-2021-21029 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 11 Feb 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-21029 and fix it if it is affected.\n\nWhat it is: CVE-2021-21029 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 11 Feb 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-21029 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- magento/community-edition (Packagist): affected all versions; fixed in 2.3.6-p1\n- magento/community-edition (Packagist): affected all versions; fixed in 2.3.6-p1\n- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.2\n- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.2\n- magento (Bitnami): affected all versions; fixed in 2.3.6, 2.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21029/ (Markdown: https://insights.sbomify.com/CVE-2021-21029/index.md)","id":"CVE-2021-21029","markdown":"https://insights.sbomify.com/CVE-2021-21029/index.md","name":"CVE-2021-21029","record":{"aliases":["BIT-magento-2021-21029","GHSA-jwxh-wj79-ccm6"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Magento Commerce","requires_auth":"high_privilege","summary":"Reflected XSS in Magento Commerce allows arbitrary JavaScript execution in the victim's browser, requiring admin console access for exploitation.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"adobe","cpe":[{"product":"magento","vendor":"magento"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are affected by a Reflected Cross-site Scripting vulnerability via 'file' parameter. Successful exploitation could lead to arbitrary JavaScript execution in the victim's browser. Access to the admin console is required for successful exploitation.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Magento Commerce Reflected Cross-site Scripting Vulnerability Could Lead To Arbitrary JavaScript Execution","id":"CVE-2021-21029","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"magento:magento","products":["magento:magento"],"type":"xss","year":"2021"},"n_packages":5,"n_references":1,"next":{"headline":"Magento Commerce Stored Cross-site Scripting Could Lead To Arbitrary Javascript Execution","id":"CVE-2021-21030"},"packages":[{"ecosystem":"Bitnami","fixed":["2.3.6","2.4.1"],"introduced":["0","2.4.0"],"last_affected":[],"package":"magento","purl":"pkg:bitnami/magento","source":"BIT-magento-2021-21029"},{"ecosystem":"Packagist","fixed":["2.3.6-p1"],"introduced":["0"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-jwxh-wj79-ccm6"},{"ecosystem":"Packagist","fixed":["2.3.6-p1"],"introduced":["0"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-jwxh-wj79-ccm6"},{"ecosystem":"Packagist","fixed":["2.4.2"],"introduced":["2.4.0"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-jwxh-wj79-ccm6"},{"ecosystem":"Packagist","fixed":["2.4.2"],"introduced":["2.4.0"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-jwxh-wj79-ccm6"}],"prev":{"headline":"Acrobat Reader DC Use-After-Free Vulnerability Could Lead To Arbitrary Code Execution","id":"CVE-2021-21028"},"products":["Magento Commerce"],"published":"2021-02-11","related":[{"cvss_score":9.8,"headline":"Magento php object injection vulnerability","id":"CVE-2020-9664","kev_date_added":null,"published":"2020-07-22"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9576","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9578","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9579","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9580","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9582","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9583","kev_date_added":null,"published":"2020-06-26"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Adobe"]},"summary":"Reflected XSS in Magento Commerce allows arbitrary JavaScript execution in the victim's browser, requiring admin console access for exploitation.","url":"https://insights.sbomify.com/CVE-2021-21029/"}