# CVE-2021-21029: Magento Commerce Reflected Cross-site Scripting Vulnerability Could Lead To Arbitrary JavaScript Execution

> Reflected XSS in Magento Commerce allows arbitrary JavaScript execution in the victim's browser, requiring admin console access for exploitation.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Feb 2021
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-magento-2021-21029, GHSA-jwxh-wj79-ccm6

## What is CVE-2021-21029?

CVE-2021-21029 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 11 Feb 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are affected by a Reflected Cross-site Scripting vulnerability via 'file' parameter. Successful exploitation could lead to arbitrary JavaScript execution in the victim's browser. Access to the admin console is required for successful exploitation.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-21029?

5 open source packages ship an affected version, including magento/community-edition and magento. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | All versions | 2.3.6-p1 |
| `magento/community-edition` | Packagist | All versions | 2.3.6-p1 |
| `magento/community-edition` | Packagist | From 2.4.0 | 2.4.2 |
| `magento/community-edition` | Packagist | From 2.4.0 | 2.4.2 |
| `magento` | Bitnami | All versions | 2.3.6, 2.4.1 |

Products: Magento Magento.

## How do I fix CVE-2021-21029?

Upgrade magento/community-edition to a fixed version for your release line: 2.3.6-p1 or 2.4.2.

## Is CVE-2021-21029 being exploited?

There is no known exploitation of CVE-2021-21029 in the wild and no public exploit code.

## Other vulnerabilities in Magento Magento

- [CVE-2020-9664](https://insights.sbomify.com/CVE-2020-9664/): Magento php object injection vulnerability (critical 9.8)
- [CVE-2020-9576](https://insights.sbomify.com/CVE-2020-9576/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9578](https://insights.sbomify.com/CVE-2020-9578/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9579](https://insights.sbomify.com/CVE-2020-9579/): Magento Security mitigation bypass vulnerability (critical 9.8)
- [CVE-2020-9580](https://insights.sbomify.com/CVE-2020-9580/): Magento Security mitigation bypass vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21029 and fix it if it is affected.

What it is: CVE-2021-21029 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 11 Feb 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21029 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected all versions; fixed in 2.3.6-p1
- magento/community-edition (Packagist): affected all versions; fixed in 2.3.6-p1
- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.2
- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.2
- magento (Bitnami): affected all versions; fixed in 2.3.6, 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21029/ (Markdown: https://insights.sbomify.com/CVE-2021-21029/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21029
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21029
- OSV: https://osv.dev/vulnerability/CVE-2021-21029

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21029/
Summaries are generated and may contain mistakes; the official description above is the record.
