CVE-2021-21032 Magento Commerce Failure To Invalidate User Session Could Lead To Unauthorized Access
Attackers can gain unauthorized access to restricted resources due to inadequate session invalidation in Magento Commerce.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-21032?
CVE-2021-21032 is a medium-severity authentication bypass vulnerability in Magento Magento, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) do not adequately invalidate user sessions. Successful exploitation of this issue could lead to unauthorized access to restricted resources. Access to the admin console is not required for successful exploitation.
Weakness: CWE-613
Which versions are affected by CVE-2021-21032?
7 open source packages ship an affected version, including magento/community-edition, magento and magento/project-community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | 2.3.6 |
magento/community-edition Packagist | All versions | 2.3.6 |
magento/community-edition Packagist | From 2.4.0 | 2.4.1-p1 |
magento/community-edition Packagist | From 2.4.0 | 2.4.1-p1 |
magento Bitnami | All versions | 2.3.6, 2.4.1 |
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
1 more packages
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
Products include Magento Magento.
How do I fix CVE-2021-21032?
Upgrade magento/community-edition to a fixed version for your release line: 2.3.6 or 2.4.1-p1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2021-21032 being exploited?
There is no known exploitation of CVE-2021-21032 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as BIT-magento-2021-21032, GHSA-4jfq-f8hc-775q.