# CVE-2021-21043: Reflected Cross-site Scripting (XSS) on version-compare and page-compare tools

> Attackers can inject malicious JavaScript into version-compare and page-compare tools, executing it in victims' browsers via reflected XSS.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Feb 2021
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-7r83-w6r8-fh6w

## What is CVE-2021-21043?

CVE-2021-21043 is a medium-severity cross-site scripting vulnerability in Adobe Experience Manager, published on 2 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

ACS Commons version 4.9.2 (and earlier) suffers from a Reflected Cross-site Scripting (XSS) vulnerability in version-compare and page-compare due to invalid JCR characters that are not handled correctly. An attacker could potentially exploit this vulnerability to inject malicious JavaScript content into vulnerable form fields and execute it within the context of the victim's browser. Exploitation of this issue requires user interaction in order to be successful.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-21043?

2 open source packages ship an affected version, including com.adobe.acs:acs-aem-commons. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.adobe.acs:acs-aem-commons` | Maven | All versions | 4.10.0 |
| `com.adobe.acs:acs-aem-commons` | Maven | All versions | 4.10.0 |

Products: Adobe Adobe Consulting Services Commons.

## How do I fix CVE-2021-21043?

Upgrade com.adobe.acs:acs-aem-commons to 4.10.0 or later.

## Is CVE-2021-21043 being exploited?

There is no known exploitation of CVE-2021-21043 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21043 and fix it if it is affected.

What it is: CVE-2021-21043 is a medium-severity cross-site scripting vulnerability in Adobe Experience Manager, published on 2 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21043 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.adobe.acs:acs-aem-commons (Maven): affected all versions; fixed in 4.10.0
- com.adobe.acs:acs-aem-commons (Maven): affected all versions; fixed in 4.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21043/ (Markdown: https://insights.sbomify.com/CVE-2021-21043/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21043
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21043
- OSV: https://osv.dev/vulnerability/CVE-2021-21043

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21043/
Summaries are generated and may contain mistakes; the official description above is the record.
