{"answers":{"affected":"It affects 3 products.","exploited":"Yes. Attackers have exploited CVE-2021-21148 in the wild since at least 3 Nov 2021.","fix":"Upgrade to a fixed version. US federal agencies must fix it by 17 Nov 2021.","what":"CVE-2021-21148 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 9 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-21148 and fix it if it is affected.\n\nWhat it is: CVE-2021-21148 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 9 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: Yes. Attackers have exploited CVE-2021-21148 in the wild since at least 3 Nov 2021.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21148/ (Markdown: https://insights.sbomify.com/CVE-2021-21148/index.md)","id":"CVE-2021-21148","markdown":"https://insights.sbomify.com/CVE-2021-21148/index.md","name":"CVE-2021-21148","record":{"aliases":["ALPINE-CVE-2021-21148","CLEANSTART-2026-NN99657","CLEANSTART-2026-RL59134","DEBIAN-CVE-2021-21148","GHSA-6675-f3rx-hqr9","UBUNTU-CVE-2021-21148","openSUSE-SU-2021:0267-1","openSUSE-SU-2021:0276-1","openSUSE-SU-2021:0296-1"],"analysis":{"component_type":"browser","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Google Chrome","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via heap corruption in V8 by tricking users into visiting a crafted HTML page.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Chrome","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"chrome","vendor":"google"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"Heap buffer overflow in V8 in Google Chrome prior to 88.0.4324.150 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.","ecosystems":["SUSE:Package Hub 15 SP2","openSUSE:Leap 15.2","openSUSE:Leap 15.2 NonFree"],"exploits":{"exploitdb":0,"first_seen":"2021-02-07","github_poc":1,"max_poc_stars":2,"metasploit":0,"nuclei":0,"refs":[{"date":"2021-02-07T09:59:47Z","kind":"github_poc","ref":"https://github.com/Grayhaxor/CVE-2021-21148","stars":2,"title":null}],"tier":"exploited"},"has_fix":true,"headline":"Google Chromium V8 Heap Buffer Overflow","id":"CVE-2021-21148","indexable":true,"kev":{"dateAdded":"2021-11-03","dueDate":"2021-11-17","knownRansomwareCampaignUse":"Unknown","product":"Chromium V8","requiredAction":"Apply updates per vendor instructions.","vendorProject":"Google","vulnerabilityName":"Google Chromium V8 Heap Buffer Overflow Vulnerability"},"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora","google:chrome"],"type":"memory_corruption","year":"2021"},"n_packages":3,"n_references":7,"next":{"headline":"Memory corruption in Chrome","id":"CVE-2021-21149"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP2","fixed":["88.0.4324.150-bp152.2.59.1"],"introduced":["0"],"last_affected":[],"package":"chromium","purl":"pkg:rpm/suse/chromium\u0026distro=SUSE%20Package%20Hub%2015%20SP2","source":"openSUSE-SU-2021:0276-1"},{"ecosystem":"openSUSE:Leap 15.2","fixed":["88.0.4324.150-lp152.2.72.1"],"introduced":["0"],"last_affected":[],"package":"chromium","purl":"pkg:rpm/opensuse/chromium\u0026distro=openSUSE%20Leap%2015.2","source":"openSUSE-SU-2021:0267-1"},{"ecosystem":"openSUSE:Leap 15.2 NonFree","fixed":["74.0.3911.107-lp152.2.34.1"],"introduced":["0"],"last_affected":[],"package":"opera","purl":"pkg:rpm/opensuse/opera\u0026distro=openSUSE%20Leap%2015.2%20NonFree","source":"openSUSE-SU-2021:0296-1"}],"prev":{"headline":"Other in Chrome","id":"CVE-2021-21147"},"products":["Chrome"],"published":"2021-02-09","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"open","licence":"CC0 1.0","name":"CISA KEV"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"active","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-10-21","vendors":["Google"]},"summary":"Remote attackers can execute arbitrary code via heap corruption in V8 by tricking users into visiting a crafted HTML page.","url":"https://insights.sbomify.com/CVE-2021-21148/"}