{"answers":{"affected":"3 open source packages ship an affected version, including pysaml2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21238 in the wild and no public exploit code.","fix":"Upgrade pysaml2 to 6.5.0 or later.","what":"CVE-2021-21238 is a medium-severity vulnerability in IdentityPython pysaml2, published on 21 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-21238 and fix it if it is affected.\n\nWhat it is: CVE-2021-21238 is a medium-severity vulnerability in IdentityPython pysaml2, published on 21 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-21238 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pysaml2 (PyPI): affected all versions; fixed in 6.5.0\n- pysaml2 (PyPI): affected all versions; fixed in 6.5.0\n- pysaml2 (PyPI): affected all versions; fixed in 6.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21238/ (Markdown: https://insights.sbomify.com/CVE-2021-21238/index.md)","id":"CVE-2021-21238","markdown":"https://insights.sbomify.com/CVE-2021-21238/index.md","name":"CVE-2021-21238","record":{"aliases":["DEBIAN-CVE-2021-21238","GHSA-f4g9-h89h-jgv9","PYSEC-2021-48","UBUNTU-CVE-2021-21238"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python SAML library","requires_auth":"none","summary":"Attackers can bypass SAML signature validation in PySAML2 by using XML signature wrapping, allowing unauthorized access to protected resources.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pysaml2","vendor":"pysaml2_project"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"PySAML2 is a pure python implementation of SAML Version 2 Standard. PySAML2 before 6.5.0 has an improper verification of cryptographic signature vulnerability. All users of pysaml2 that need to validate signed SAML documents are impacted. The vulnerability is a variant of XML Signature wrapping because it did not validate the SAML document against an XML schema. This allowed invalid XML documents to be processed and such a document can trick pysaml2 with a wrapped signature. This is fixed in PySAML2 6.5.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SAML XML Signature wrapping","id":"CVE-2021-21238","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2021"},"n_packages":3,"n_references":4,"next":{"headline":"Open default xmlsec1 key-type preference","id":"CVE-2021-21239"},"packages":[{"ecosystem":"PyPI","fixed":["6.5.0"],"introduced":["0"],"last_affected":[],"package":"pysaml2","purl":null,"source":"GHSA-f4g9-h89h-jgv9"},{"ecosystem":"PyPI","fixed":["6.5.0"],"introduced":["0"],"last_affected":[],"package":"pysaml2","purl":"pkg:pypi/pysaml2","source":"GHSA-f4g9-h89h-jgv9"},{"ecosystem":"PyPI","fixed":["6.5.0"],"introduced":["0"],"last_affected":[],"package":"pysaml2","purl":"pkg:pypi/pysaml2","source":"PYSEC-2021-48"}],"prev":{"headline":"Git LFS can execute a Git binary from the current directory on Windows","id":"CVE-2021-21237"},"products":["pysaml2"],"published":"2021-01-21","related":[{"cvss_score":9,"headline":"PySAML2 XML external entity attack","id":"CVE-2016-10127","kev_date_added":null,"published":"2017-03-03"},{"cvss_score":5.3,"headline":"Pysaml2 improperly initializes encryption vector","id":"CVE-2017-1000246","kev_date_added":null,"published":"2017-11-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["IdentityPython"]},"summary":"Attackers can bypass SAML signature validation in PySAML2 by using XML signature wrapping, allowing unauthorized access to protected resources.","url":"https://insights.sbomify.com/CVE-2021-21238/"}