# CVE-2021-21238: SAML XML Signature wrapping

> Attackers can bypass SAML signature validation in PySAML2 by using XML signature wrapping, allowing unauthorized access to protected resources.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Jan 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-21238, GHSA-f4g9-h89h-jgv9, PYSEC-2021-48, UBUNTU-CVE-2021-21238

## What is CVE-2021-21238?

CVE-2021-21238 is a medium-severity vulnerability in IdentityPython pysaml2, published on 21 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PySAML2 is a pure python implementation of SAML Version 2 Standard. PySAML2 before 6.5.0 has an improper verification of cryptographic signature vulnerability. All users of pysaml2 that need to validate signed SAML documents are impacted. The vulnerability is a variant of XML Signature wrapping because it did not validate the SAML document against an XML schema. This allowed invalid XML documents to be processed and such a document can trick pysaml2 with a wrapped signature. This is fixed in PySAML2 6.5.0.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2021-21238?

3 open source packages ship an affected version, including pysaml2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pysaml2` | PyPI | All versions | 6.5.0 |
| `pysaml2` | PyPI | All versions | 6.5.0 |
| `pysaml2` | PyPI | All versions | 6.5.0 |

Products: Pysaml2 Project Pysaml2.

## How do I fix CVE-2021-21238?

Upgrade pysaml2 to 6.5.0 or later.

## Is CVE-2021-21238 being exploited?

There is no known exploitation of CVE-2021-21238 in the wild and no public exploit code.

## Other vulnerabilities in IdentityPython pysaml2

- [CVE-2016-10127](https://insights.sbomify.com/CVE-2016-10127/): PySAML2 XML external entity attack (critical 9.0)
- [CVE-2017-1000246](https://insights.sbomify.com/CVE-2017-1000246/): Pysaml2 improperly initializes encryption vector (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21238 and fix it if it is affected.

What it is: CVE-2021-21238 is a medium-severity vulnerability in IdentityPython pysaml2, published on 21 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21238 in the wild and no public exploit code.

Affected packages and fixed versions:
- pysaml2 (PyPI): affected all versions; fixed in 6.5.0
- pysaml2 (PyPI): affected all versions; fixed in 6.5.0
- pysaml2 (PyPI): affected all versions; fixed in 6.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21238/ (Markdown: https://insights.sbomify.com/CVE-2021-21238/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21238
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21238
- OSV: https://osv.dev/vulnerability/CVE-2021-21238

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21238/
Summaries are generated and may contain mistakes; the official description above is the record.
