{"answers":{"affected":"3 open source packages ship an affected version, including httplib2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21240 in the wild and no public exploit code.","fix":"Upgrade httplib2 to 0.19.0 or later.","what":"CVE-2021-21240 is a high-severity denial of service vulnerability in httplib2, published on 8 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21240 and fix it if it is affected.\n\nWhat it is: CVE-2021-21240 is a high-severity denial of service vulnerability in httplib2, published on 8 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21240 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- httplib2 (PyPI): affected all versions; fixed in 0.19.0\n- httplib2 (PyPI): affected all versions; fixed in 0.19.0\n- httplib2 (PyPI): affected all versions; fixed in 0.19.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21240/ (Markdown: https://insights.sbomify.com/CVE-2021-21240/index.md)","id":"CVE-2021-21240","markdown":"https://insights.sbomify.com/CVE-2021-21240/index.md","name":"CVE-2021-21240","record":{"aliases":["DEBIAN-CVE-2021-21240","GHSA-93xj-8mrv-444m","MGASA-2021-0122","OESA-2021-1126","PYSEC-2021-16","UBUNTU-CVE-2021-21240"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python HTTP client library","requires_auth":"none","summary":"A malicious server can cause a denial of service in the httplib2 Python library by sending crafted authentication headers, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"httplib2","vendor":"httplib2_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"httplib2 is a comprehensive HTTP client library for Python. In httplib2 before version 0.19.0, a malicious server which responds with long series of \"\\xa0\" characters in the \"www-authenticate\" header may cause Denial of Service (CPU burn while parsing header) of the httplib2 client accessing said server. This is fixed in version 0.19.0 which contains a new implementation of auth headers parsing using the pyparsing library.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service in httplib2","id":"CVE-2021-21240","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":3,"n_references":4,"next":{"headline":"CSRF can expose users authentication token in Flask-Security-Too","id":"CVE-2021-21241"},"packages":[{"ecosystem":"PyPI","fixed":["0.19.0"],"introduced":["0"],"last_affected":[],"package":"httplib2","purl":null,"source":"GHSA-93xj-8mrv-444m"},{"ecosystem":"PyPI","fixed":["0.19.0"],"introduced":["0"],"last_affected":[],"package":"httplib2","purl":"pkg:pypi/httplib2","source":"GHSA-93xj-8mrv-444m"},{"ecosystem":"PyPI","fixed":["0.19.0"],"introduced":["0"],"last_affected":[],"package":"httplib2","purl":"pkg:pypi/httplib2","source":"PYSEC-2021-16"}],"prev":{"headline":"Open default xmlsec1 key-type preference","id":"CVE-2021-21239"},"products":["httplib2"],"published":"2021-02-08","related":[{"cvss_score":7.5,"headline":"httplib2: Decompression Bomb Denial of Service via Unbounded gzip/deflate Response Handling","id":"CVE-2026-59939","kev_date_added":null,"published":"2026-07-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["httplib2"]},"summary":"A malicious server can cause a denial of service in the httplib2 Python library by sending crafted authentication headers, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2021-21240/"}