# CVE-2021-21240: Regular Expression Denial of Service in httplib2

> A malicious server can cause a denial of service in the httplib2 Python library by sending crafted authentication headers, requiring an upgrade to fix.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-21240, GHSA-93xj-8mrv-444m, MGASA-2021-0122, OESA-2021-1126, PYSEC-2021-16, UBUNTU-CVE-2021-21240

## What is CVE-2021-21240?

CVE-2021-21240 is a high-severity denial of service vulnerability in httplib2, published on 8 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

httplib2 is a comprehensive HTTP client library for Python. In httplib2 before version 0.19.0, a malicious server which responds with long series of "\xa0" characters in the "www-authenticate" header may cause Denial of Service (CPU burn while parsing header) of the httplib2 client accessing said server. This is fixed in version 0.19.0 which contains a new implementation of auth headers parsing using the pyparsing library.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-21240?

3 open source packages ship an affected version, including httplib2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `httplib2` | PyPI | All versions | 0.19.0 |
| `httplib2` | PyPI | All versions | 0.19.0 |
| `httplib2` | PyPI | All versions | 0.19.0 |

Products: Httplib2 Project Httplib2.

## How do I fix CVE-2021-21240?

Upgrade httplib2 to 0.19.0 or later.

## Is CVE-2021-21240 being exploited?

There is no known exploitation of CVE-2021-21240 in the wild and no public exploit code.

## Other vulnerabilities in httplib2

- [CVE-2026-59939](https://insights.sbomify.com/CVE-2026-59939/): httplib2: Decompression Bomb Denial of Service via Unbounded gzip/deflate Response Handling (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21240 and fix it if it is affected.

What it is: CVE-2021-21240 is a high-severity denial of service vulnerability in httplib2, published on 8 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21240 in the wild and no public exploit code.

Affected packages and fixed versions:
- httplib2 (PyPI): affected all versions; fixed in 0.19.0
- httplib2 (PyPI): affected all versions; fixed in 0.19.0
- httplib2 (PyPI): affected all versions; fixed in 0.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21240/ (Markdown: https://insights.sbomify.com/CVE-2021-21240/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21240
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21240
- OSV: https://osv.dev/vulnerability/CVE-2021-21240

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21240/
Summaries are generated and may contain mistakes; the official description above is the record.
