{"answers":{"affected":"4 open source packages ship an affected version, including jQuery.Validation and jquery-validation. It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-21252 in the wild and no public exploit code.","fix":"Upgrade jQuery.Validation to 1.19.3 or later.","what":"CVE-2021-21252 is a medium-severity denial of service vulnerability in Netapp Snapcenter, published on 13 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21252 and fix it if it is affected.\n\nWhat it is: CVE-2021-21252 is a medium-severity denial of service vulnerability in Netapp Snapcenter, published on 13 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21252 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jQuery.Validation (NuGet): affected all versions; fixed in 1.19.3\n- jQuery.Validation (NuGet): affected all versions; fixed in 1.19.3\n- jquery-validation (npm): affected all versions; fixed in 1.19.3\n- jquery-validation (npm): affected all versions; fixed in 1.19.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21252/ (Markdown: https://insights.sbomify.com/CVE-2021-21252/index.md)","id":"CVE-2021-21252","markdown":"https://insights.sbomify.com/CVE-2021-21252/index.md","name":"CVE-2021-21252","record":{"aliases":["DEBIAN-CVE-2021-21252","GHSA-jxwx-85vp-gvwm","UBUNTU-CVE-2021-21252"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"jQuery validation library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using the jQuery Validation Plugin by exploiting vulnerable regular expressions.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"jquery_validation","vendor":"jqueryvalidation"},{"product":"snapcenter","vendor":"netapp"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"The jQuery Validation Plugin provides drop-in validation for your existing forms. It is published as an npm package \"jquery-validation\". jquery-validation before version 1.19.3 contains one or more regular expressions that are vulnerable to ReDoS (Regular Expression Denial of Service). This is fixed in 1.19.3.","ecosystems":["NuGet","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular expression denial of service in jquery-validation","id":"CVE-2021-21252","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":"netapp:snapcenter","products":["netapp:snapcenter"],"type":"denial_of_service","year":"2021"},"n_packages":4,"n_references":6,"next":{"headline":"Use of a One-Way Hash without a Salt in OnlineVotingSystem","id":"CVE-2021-21253"},"packages":[{"ecosystem":"NuGet","fixed":["1.19.3"],"introduced":["0"],"last_affected":[],"package":"jQuery.Validation","purl":null,"source":"GHSA-jxwx-85vp-gvwm"},{"ecosystem":"NuGet","fixed":["1.19.3"],"introduced":["0"],"last_affected":[],"package":"jQuery.Validation","purl":"pkg:nuget/jQuery.Validation","source":"GHSA-jxwx-85vp-gvwm"},{"ecosystem":"npm","fixed":["1.19.3"],"introduced":["0"],"last_affected":[],"package":"jquery-validation","purl":null,"source":"GHSA-jxwx-85vp-gvwm"},{"ecosystem":"npm","fixed":["1.19.3"],"introduced":["0"],"last_affected":[],"package":"jquery-validation","purl":"pkg:npm/jquery-validation","source":"GHSA-jxwx-85vp-gvwm"}],"prev":{"headline":"ZipSlip Arbitrary File Upload","id":"CVE-2021-21251"},"products":["jquery-validation"],"published":"2021-01-13","related":[{"cvss_score":7.5,"headline":"jquery-validation ReDoS in url2 due to incomplete fix of CVE-2021-43306","id":"CVE-2022-31147","kev_date_added":null,"published":"2022-07-14"},{"cvss_score":5.9,"headline":"Exponential ReDoS in jquery-validation","id":"CVE-2021-43306","kev_date_added":null,"published":"2022-06-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["jquery-validation"]},"summary":"An attacker can cause a denial of service in applications using the jQuery Validation Plugin by exploiting vulnerable regular expressions.","url":"https://insights.sbomify.com/CVE-2021-21252/"}