{"answers":{"affected":"2 open source packages ship an affected version, including @ckeditor/ckeditor5-markdown-gfm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21254 in the wild and no public exploit code.","fix":"Upgrade @ckeditor/ckeditor5-markdown-gfm to 25.0.0 or later.","what":"CVE-2021-21254 is a medium-severity denial of service vulnerability in ckeditor5, published on 29 Jan 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21254 and fix it if it is affected.\n\nWhat it is: CVE-2021-21254 is a medium-severity denial of service vulnerability in ckeditor5, published on 29 Jan 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21254 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @ckeditor/ckeditor5-markdown-gfm (npm): affected all versions; fixed in 25.0.0\n- @ckeditor/ckeditor5-markdown-gfm (npm): affected all versions; fixed in 25.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21254/ (Markdown: https://insights.sbomify.com/CVE-2021-21254/index.md)","id":"CVE-2021-21254","markdown":"https://insights.sbomify.com/CVE-2021-21254/index.md","name":"CVE-2021-21254","record":{"aliases":["GHSA-hgmg-hhc8-g5wr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript rich text editor","requires_auth":"low_privilege","summary":"An attacker can cause a browser tab freeze in CKEditor 5 Markdown plugin via a regex denial of service attack.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ckeditor5","vendor":"ckeditor"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"CKEditor 5 is an open source rich text editor framework with a modular architecture. The CKEditor 5 Markdown plugin (@ckeditor/ckeditor5-markdown-gfm) before version 25.0.0 has a regex denial of service (ReDoS) vulnerability. The vulnerability allowed to abuse link recognition regular expression, which could cause a significant performance drop resulting in browser tab freeze. It affects all users using CKEditor 5 Markdown plugin at version \u003c= 24.0.0. The problem has been recognized and patched. The fix will be available in version 25.0.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular expression Denial of Service in Markdown plugin","id":"CVE-2021-21254","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"entities switch IDOR","id":"CVE-2021-21255"},"packages":[{"ecosystem":"npm","fixed":["25.0.0"],"introduced":["0"],"last_affected":[],"package":"@ckeditor/ckeditor5-markdown-gfm","purl":null,"source":"GHSA-hgmg-hhc8-g5wr"},{"ecosystem":"npm","fixed":["25.0.0"],"introduced":["0"],"last_affected":[],"package":"@ckeditor/ckeditor5-markdown-gfm","purl":"pkg:npm/%40ckeditor/ckeditor5-markdown-gfm","source":"GHSA-hgmg-hhc8-g5wr"}],"prev":{"headline":"Use of a One-Way Hash without a Salt in OnlineVotingSystem","id":"CVE-2021-21253"},"products":["ckeditor5"],"published":"2021-01-29","related":[{"cvss_score":6.4,"headline":"CKEditor: Cross-site scripting (XSS) in the HTML Support package","id":"CVE-2026-28343","kev_date_added":null,"published":"2026-03-05"},{"cvss_score":5.1,"headline":"CKEditor 5 has Cross-site Scripting vulnerability in the clipboard package","id":"CVE-2024-45613","kev_date_added":null,"published":"2024-09-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["ckeditor"]},"summary":"An attacker can cause a browser tab freeze in CKEditor 5 Markdown plugin via a regex denial of service attack.","url":"https://insights.sbomify.com/CVE-2021-21254/"}