CVE-2021-21258 XSS injection in ajax/kanban

Medium 6.8 Published Updated

Attackers can inject malicious scripts via the kanban AJAX endpoint in GLPI, potentially leading to session hijacking or code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2021-21258?

CVE-2021-21258 is a medium-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 2 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI from version 9.5.0 and before version 9.5.4, there is a cross-site scripting injection vulnerability when using ajax/kanban.php. This is fixed in version 9.5.4.

Weakness: CWE-79

Which versions are affected by CVE-2021-21258?

It affects 1 product.

Products include Glpi-Project Glpi.

How do I fix CVE-2021-21258?

No fix has been published for CVE-2021-21258 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-21258 being exploited?

There is no known exploitation of CVE-2021-21258 in the wild and no public exploit code.

All Glpi-Project Glpi vulnerabilities

Sources

Also known as GHSA-j4xj-4qmc-mmmx, UBUNTU-CVE-2021-21258.

Is CVE-2021-21258 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free