{"answers":{"affected":"2 open source packages ship an affected version, including schema-inspector. It affects 3 products.","exploited":"There is no known exploitation of CVE-2021-21267 in the wild and no public exploit code.","fix":"Upgrade schema-inspector to 2.0.0 or later.","what":"CVE-2021-21267 is a high-severity denial of service vulnerability in Netapp E-Series Performance Analyzer, published on 19 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21267 and fix it if it is affected.\n\nWhat it is: CVE-2021-21267 is a high-severity denial of service vulnerability in Netapp E-Series Performance Analyzer, published on 19 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21267 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- schema-inspector (npm): affected all versions; fixed in 2.0.0\n- schema-inspector (npm): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21267/ (Markdown: https://insights.sbomify.com/CVE-2021-21267/index.md)","id":"CVE-2021-21267","markdown":"https://insights.sbomify.com/CVE-2021-21267/index.md","name":"CVE-2021-21267","record":{"aliases":["GHSA-f38p-c2gq-4pmr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"npm validation library","requires_auth":"none","summary":"An attacker can cause a denial of service by providing a specially crafted email address to the schema-inspector library, freezing the application.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"e-series_performance_analyzer","vendor":"netapp"},{"product":"oncommand_insight","vendor":"netapp"},{"product":"schema-inspector","vendor":"schema-inspector_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Schema-Inspector is an open-source tool to sanitize and validate JS objects (npm package schema-inspector). In before version 2.0.0, email address validation is vulnerable to a denial-of-service attack where some input (for example `a@0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.`) will freeze the program or web browser page executing the code. This affects any current schema-inspector users using any version to validate email addresses. Users who do not do email validation, and instead do other types of validation (like string min or max length, etc), are not affected. Users should upgrade to version 2.0.0, which uses a regex expression that isn't vulnerable to ReDoS.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial-of-Service in npm schema-inspector","id":"CVE-2021-21267","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"netapp:e-series_performance_analyzer","products":["netapp:e-series_performance_analyzer","netapp:oncommand_insight"],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"Path Traversal in Keymaker","id":"CVE-2021-21269"},"packages":[{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"schema-inspector","purl":null,"source":"GHSA-f38p-c2gq-4pmr"},{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"schema-inspector","purl":"pkg:npm/schema-inspector","source":"GHSA-f38p-c2gq-4pmr"}],"prev":{"headline":"XXE vulnerability in OpenHAB","id":"CVE-2021-21266"},"products":["schema-inspector"],"published":"2021-03-19","related":[{"cvss_score":5.3,"headline":"ReDoS in Sec-Websocket-Protocol header","id":"CVE-2021-32640","kev_date_added":null,"published":"2021-05-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["schema-inspector"]},"summary":"An attacker can cause a denial of service by providing a specially crafted email address to the schema-inspector library, freezing the application.","url":"https://insights.sbomify.com/CVE-2021-21267/"}